Windows 8 audio switching problem - solved - I guess.

Discussion in 'Operating Systems' started by mxnerd, Nov 8, 2012.

  1. mxnerd

    mxnerd Platinum Member

    Joined:
    Jul 6, 2007
    Messages:
    2,538
    Likes Received:
    133
    Bought Windows 8 Pro 2 days ago. Did a fresh install. I loved the snappy performance of it.

    Then I found that it has serious problem with audio switching. Whenever I switched from one audio device to another device, let's say from HDMI audio to speaker (make it default), or vice versa, then Windows 8 lost the audio completely, couldn't hear anything even if I switch back to the original audio device.

    The only way to get it back was reboot the machine! Anyone experience this?

    Edit
    =====
    Found that I only need to restart the application, no need to restart Windows 8
     
    #1 mxnerd, Nov 8, 2012
    Last edited: Nov 16, 2012
  2. Loading...

    Similar Threads - Windows audio switching Forum Date
    Audio snobs rejoice: Windows 10 will have system-wide FLAC support Operating Systems Nov 26, 2014
    Windows 8.1 freezes (crappy audio driver?) Operating Systems Jun 12, 2014
    Windows 7 audio driver and Asus M3A78-EM Operating Systems May 16, 2014
    No audio output device is installed - fresh windows 7 install Operating Systems Dec 2, 2012
    Windows 7 + USB audio = no boot Operating Systems Jan 9, 2011

  3. shankly1985

    shankly1985 Junior Member

    Joined:
    Nov 7, 2012
    Messages:
    3
    Likes Received:
    0
    Not got this but I do have High Latency and audio stutters.
     
  4. mxnerd

    mxnerd Platinum Member

    Joined:
    Jul 6, 2007
    Messages:
    2,538
    Likes Received:
    133
    Could be Google Chrome's (v23) problem.

    Watching video on Chrome and switch audio, then audio is gone. Yet click the test button I can hear audio coming out clearly, but not from youtube video.

    Using Firefox and switch audio, and Firefox's audio still functions properly.

    Will do more test.
     
  5. mxnerd

    mxnerd Platinum Member

    Joined:
    Jul 6, 2007
    Messages:
    2,538
    Likes Received:
    133
    Seems that sometimes it works, sometimes it doesn't. Tried Firefox yet again and this time same symptom as Chrome. Think it still could be Windows 8's problem. :(