Windows 2000 File Sharing - Am I safe from hackers?

gsaldivar

Diamond Member
Apr 30, 2001
8,691
1
0
My main computer, and a laptop are on a LAN connected with a Netopia R9100 router/firewall.

I've got W2K Pro on both machines. I have mapped each HD onto the other machine, set to mount at boot.

The admin account on both machines has a password, but both machines are set to login automatically with TweakUI.

When I mount each HD through the network, I am not prompted for a password (shouldn't I be?). I am using the admin "C$", "D$" sharing method. (I have not specified extra share points).

Am I safe from people that might try to access my computer through the Internet?

Is there a log somewhere that I can check to make sure I am the only one that has been logging in?

Thanks guys!!!

:D
 

Nothinman

Elite Member
Sep 14, 2001
30,672
0
0
When I mount each HD through the network, I am not prompted for a password (shouldn't I be?). I am using the admin "C$", "D$" sharing method. (I have not specified extra share points).

Windows caches your password and tries to log you in with it automatically when you map a drive so no, if the passwords are the same you don't be prompted.

Am I safe from people that might try to access my computer through the Internet?

Depending on whether the Netopia sucks or not.

Is there a log somewhere that I can check to make sure I am the only one that has been logging in?

You would have to enable auditing, by default there's no logs.
 

gsaldivar

Diamond Member
Apr 30, 2001
8,691
1
0
Thanks for your help Nothinman!

I found a website that checks my IP for any vulnerabilities and the netopia seems to look like it's holding up great.

I found some log tools in Control Panels > Administrative Tools > Computer Management. But I can't figure out how to turn ON logging of each access to my shared drives. I also found in Windows help somewhere it says that by default there are no logs -

Can you please tell me how to activate the logging?

Thanks! :) :)
 

Saltin

Platinum Member
Jul 21, 2001
2,175
0
0
Auditing is turned on via Group Policy.

From the run line, enter gpedit.msc
In the window that opens, expand Computer Configuration>Windows Settings>Security Settings>Local Policies>Audit Policies.
Here you will see the various audit policies. You want to enable auditing for "Object Access" (Objects are things like files, folders and harddrives) Right click that policy and select properties, there you can enable it. You should decide wether you want to audit Success ( meaning it logs every successfull access of the object) , Failure ( meaning it logs someone who attempts to access the object, but was denied access) or you can audit both success and failure.

Once you have enable auditing, you should go to the files/folders/drives you actually want to audit, and enable the auditing there (Properties>Security>Advanced>Auditing.

You can view the logs at any time under computer management, Event viewer, Security.

Good luck
 

gsaldivar

Diamond Member
Apr 30, 2001
8,691
1
0
ONE last question:

On my laptop, when I right-click one of my drives, I see two additional tabs that are NOT on my desktop computer: "Security" and "Quota".

How do I get these tabs to "reappear" on my main system?


THANKS for the help guys! :D
 

Saltin

Platinum Member
Jul 21, 2001
2,175
0
0
I'm guessing your laptop is using the NTFS file system, and your desktop is using FAT32.
You would need to format your Desktop's HD to NTFS to get the security and quota options, which are not available in a FAT32 file system.
 

gsaldivar

Diamond Member
Apr 30, 2001
8,691
1
0
o damm, you're right - lappy is NTFS and home system is FAT32.

ok - next time I reformat, I know what to do... thank you thank you! :)


 

Nothinman

Elite Member
Sep 14, 2001
30,672
0
0
You can convert from FAT32->NTFS with the convert command, but you can't go back to FAT32 so easily.