• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."
  • Community Question: What makes a good motherboard?

Windows 10 just refuses to keep time.

BarkingGhostar

Diamond Member
Nov 20, 2009
7,650
893
126
I've searched, read and tried everything I could find within reason to fix this problem but every time I boot up Windows 10 professional 64-bit the time is always off by five hours. The one thing I did find strange was the Windows Time service was set to manual, and it wasn't running. I started it and changed it to Automatic (not the Automatic with delay). I then rebooted and that made no difference even though I verified the Windows Time service was actually running. Everything you would expect to be to have this working I've done and yet Windows continues to be five hours off. I did see one suggestion which was to change the time interval to something from seven days (default) to once a day, or even less, which warned me that if I go under four seconds I could get my IP banned--reasonable. I chose not to change it but I am thoroughly baffled by Windows 10 just not performing a time sync on boot.

Its not the CMOS battery! I check the BIOS and the date and time is correct there. If i boot into Windows 7 Pro it reports the time and date just fine. Linux Mint 18.4 also reports the time and date just fine. But this SOB Windows 10 just won't. Yes, it is set to use time.windows.com and this behavior started from the beginning but currently at Version 2003 (Build 19041.572). BTW, I am not experiencing this on other Windows 10 computers in my home--although they are Surface Pro 7's.

Not sure what else to do other than just having to manually force a sync on every boot or install a third party service, which is nonsense.
 

mxnerd

Diamond Member
Jul 6, 2007
5,594
694
126
Probably has something to do with CDN network. I also have one Win10 mini pc which always sets its time zone to China.

Try

 
Last edited:

Steltek

Platinum Member
Mar 29, 2001
2,515
347
126
It is a known problem with Windows, and I've fought with it more than once on new installs. In fact, I can't even say for sure what I did that fixed it.

I do know it was never fixable from the Adjust Date/Time menu available by right-clicking the time/date in the task bar. I think I had to mess around with the Time and Date settings app in Control Panel (it allowed me to get to the Internet Time settings tab, which isn't available otherwise) and the time sync eventually began working.
 

VirtualLarry

Lifer
Aug 25, 2001
49,494
5,580
126
By default, Win10 fresh installation set TZ to Pacific (GMT-8:00), and I have to always manually change my TZ to EDT (GMT-4:00) (ok, really GMT-5:00, with "Adjust for daylight savings time" checked off).
 

BarkingGhostar

Diamond Member
Nov 20, 2009
7,650
893
126
I always specify East Coast during the install, and it always shows that, too. What is reports in just inconsistent. It is embarrassing they could screw something so simple up and never fix it. I may need to try the folowing:


I have the same problem. When my computer not connected to the internet it shows wrong time. I knew although I set my time zone manually, it shows UTC time. So windows 10 does not consider time zone whet it is not connected to the net. I searched on the net and found a solution for it on windows report web site as bellow:
Add RealTimeIsUniversal DWORD in Registry Editor
Once Registry Editor opens, navigate to the following key in the left pane
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ControlTimeZoneInformation
Right-click the empty space and select New > QWORD (64-bit) Value.
Enter RealTimeIsUniversal as the name of the new value and double click it.
Set its Value data to 1 and click OK to save changes.
now reset your computer and set the time again. It works fine after that for me.
ps: I am using dual boot Ubuntu and windows 10.
 
Last edited:

VirtualLarry

Lifer
Aug 25, 2001
49,494
5,580
126
ps: I am using dual boot Ubuntu and windows 10.
Did you mention dual-booting with Linux, in your OP originally, or was that an additional edit? Regardless, I missed that. Yes, dual-booting Win10 with Linux requires some care over the RTC clock setting (localtime versus UCT, with or without OS offset), and OS TZ settings, and time-syncing.

This is NOT a defect in Windows 10, as the title intends to indicate. Once TZ is set, and time is synced, I've had no problems with time-keeping in Win10.

Dual-boot with Linux, though, and that's a whole nother can of worms.
 

BarkingGhostar

Diamond Member
Nov 20, 2009
7,650
893
126
I never multi-boot. I keep my OS on separate SSDs. I never allow one to interfere with the other. When an OS isn't running it is physically unplugged from SATA and power.
 

pcgeek11

Lifer
Jun 12, 2005
17,539
1,755
126
@BarkingGhostar

I don't think it matters if they are on separate disks or not. They are both interfacing the same motherboard and RTC.

Have you tried to make Linux use local time?

Give it a try. It is easy and works. This is what I do on my dual boot systems.


Make Linux use local time

Not only is this a more reliable method, changing Linux’s ways is a much simpler process too. Ask anyone who uses the command line often, they’ll tell you it’s faster and easier. As long as you know specifically what you’re after it really is. Instead of opening apps browsing through settings and all, you could simply push a command. It’s a one-step process, provided you know what exactly you want to do.


In this case, we need Linux to use to interpret the motherboard’s time as local time. That can be done with this one simple command.


timedatectl set-local-rtc 1 --adjust-system-clock

Linux will no longer apply timezone adjustments to the clock on your
motherboard. As a result, the clocks on your dual boot Windows 10 and
Linux set up will be in perfect sync. Before you reboot though you
should probably make sure it has worked. Just Enter the command below in
the Terminal.


timedatectl

In the text you’re returned, look for “RTC in local TZ: yes”. If it’s “yes” it means things have worked out. You will also see a warning that says this mode is not fully supported but you don’t worry as long as you are dual boot Windows 10 alongside Linux. Linux doesn’t handle daylight savings well with the time configured to be interpreted as local time. But Windows will take care of the daylight savings so you don’t need to worry.


In case you would ever like to undo this change, it’s as simple as entering the same command again but with 0 instead of 1.

timedatectl set-local-rtc 0 --adjust-system-clock
 
Last edited:
  • Like
Reactions: VirtualLarry

BarkingGhostar

Diamond Member
Nov 20, 2009
7,650
893
126
Not running 3rd party sw just to get the dang OS to keep time. I did notice that if I boot into this Windows PC twice in a day the second instance has the correct time. Go figure.
 

ASK THE COMMUNITY