Windows 10 Homegroup no more...best way to share files?

Uppie1414

Golden Member
Sep 1, 2003
1,803
0
81
#1
Now that homegroup is gone in Windows 10, what's my best option to have a central computer to host/save/share everything on?

Wireless network with 5 computers. I want one computer to be the main hub to have the folders (mainly excel files) and the other computers can access/save as well.

Any thoughts? Thanks!
 

Uppie1414

Golden Member
Sep 1, 2003
1,803
0
81
#3
Ahh, thanks! I appreciate it! I gotta make sure all the computers are available to connect now and not hidden.
 

Uppie1414

Golden Member
Sep 1, 2003
1,803
0
81
#4
With homegroup gone, seems like some computers aren't showing up. I thought I made them all visible.

Thoughts? Used to be so easy...bah. Just make a shared folder under the homegroup and you were good to go.
 

JackMDS

Elite Member
Super Moderator
Oct 25, 1999
28,883
62
106
#5
Make sure that they are not on HomeGroup and configured to share.


:cool:
 

Uppie1414

Golden Member
Sep 1, 2003
1,803
0
81
#6
2 new basement computers are not on homegroup. Upstairs computer made the homegroup and I can see PC1 in basement but not PC2 Both should have the same settings, but will check. Thanks again.

*all network discovery settings are at "on"
 

razel

Platinum Member
May 14, 2002
2,198
1
101
#8
I'd start over. Go to 'Computer Management' and 'Shared Folder.' Make note of any folders being shared that don't end with a '$' and unshare them. Make your way to your 'Windows Defender Firewall' and restore defaults. Now bring up 'Credentials Manager' and remove any Windows Credentials you may have used when sharing files.

Off two computers that want to read/write the share, go to File Explorer and expand the Network folder. It'll tell you to turn on 'network sharing' if your network is not set to 'private.' It can take MINUTES for other computers to show. Remember do that off those two computers.

At the same time while Windows looks for the computers, you can right click the folder you want to share and give access to the appropriate accounts. If you don't want to use username/password, then choose homegroup.

If by then computers have yet to show, you can press F5 to refresh the Network screen or just forcibly view it via \\COMPUTERNAME\ in windows explorer. If nothing happens, ping it. If you can't ping it, then you know you what's up.
 

Uppie1414

Golden Member
Sep 1, 2003
1,803
0
81
#10
Note

The HomeGroup (view) and HomeGroup (view and edit) options still appear when you right-click a folder in File Explorer, and then point to Give access to. However, neither option will do anything in Windows 10 (Version 1803). To share a file or folder, select Specific people from the same shortcut menu instead.

I can only see our sonos and roku players on the network...not other PC in the house. What gives? Homegroup was so easy...
 

razel

Platinum Member
May 14, 2002
2,198
1
101
#11
The other PCs may need to have their network set to private as well. Get on those and check what's on their Network map.
 
Aug 25, 2001
44,445
806
126
#12
I've noticed that my Win10 PCs no longer show up under Network places (I've never really used HomeGroups, never bothered, never configured). I've always used the "proper" Windows File Sharing. I also have some NAS units. The NAS units show up under Network places, but NOT the PCs. Not sure what's going on there.
 

Uppie1414

Golden Member
Sep 1, 2003
1,803
0
81
#13
Thanks. Both are set to private...this is so odd. I just want to share excel files...lol
 
Oct 13, 2005
143
0
76
#16
Consider Resilio Sync. It works great to keep a few of my PC's in sync with whatever directories I want to share.

The home version is free to share between unlimited PC's that you own.

https://www.resilio.com/individuals/
 

aigomorla

Cases and Cooling Mod PC Gaming Mod Elite Member
Super Moderator
Sep 28, 2005
17,360
114
126
#18
winkey + R => type in Services.svc

Scroll down and look for:
Function Discovery Provider Host
Function Discovery Resource Publication
UPnP Device Host
DNS Client
SSDP Discovery

Make sure they are running on all PC's which u wish to be visable on the closed network.
Also its advisable to set it up as automatic if again you are on your own private network.
 

Uppie1414

Golden Member
Sep 1, 2003
1,803
0
81
#22
Great, thanks! Working on it now. All are up and on automatic. Still cannot see the computers (they're side-by-side)
 

Uppie1414

Golden Member
Sep 1, 2003
1,803
0
81
#23
Still not working. So odd. This win10 update is terrible.
 


ASK THE COMMUNITY