Win2K boot up problem...someone should know this

FiDo14DiDo

Senior member
Apr 7, 2000
603
0
0
I have two HDD's: HHD0 has WIN98SE installed and HHD1 has WIN2K. I installed Win2K while I was running WIN98. It boots up fine and everything but the problem is that I want to remove HDD0 from my system. If I do that, however, the Win2K HDD(which is the new HDD0) will not boot. I get a boot disk failure at startup. All the settings in the BIOS were updated accordingly.

So my questions are: are there some missing boot up files that Win2K didnt install since I was running Win98 during installation? Also, can I do this without formatting the HDD with WIN2k???

Thanks
 

Slikkster

Diamond Member
Apr 29, 2000
3,141
0
0
Here's the story with Windows 2000 (and it's predecessors: Windows Nt). Even though you can install it to a different drive or partition, it still has boot files on the C: partition, or HD-0. All Windows operating systems need to "boot" from Drive C. Additionally, one of these boot files has pointers to where the "rest" of Windows 2000 resides (other than the primary boot files). That file is called "boot.ini". It's going to have some strange lines in it that mention scsi, multi, etc.

Here's one of the lines in my boot.ini file. This is the one that tells Windows 2000 that it resides on Drive D:, and on the first active partition on that drive. (remembering that drive numbers and partition numbers start with 0, but for all intents and purposes, partition numbers will always begin with 1 in these lines):



multi(0)disk(0)rdisk(1)partition(1)\winnt="Microsoft Windows 2000 Professional" /fastdetect


This line is also indicative of the fact that I'm using a SCSI controller with it's bios enabled (a Promise Ultra 66 card) that both my drives reside on. IDE controllers and SCSI controllers that have an enabled bios will be listed as "multi", the first part of the name of this line. Notice I have "rdisk(1)". That's a SCSI configuration. If you have a regular IDE controller, you probably have a line that looks like this, no?

multi(0)disk(1)rdisk(0)partition(1)\winnt="Microsoft Windows 2000" /fastdetect

In your case, this would tell you that you have "multi (0)", which means an IDE Controller number 1, Disk 1 which means the slave drive on that primary controller, rdisk 0 which means it's not a scsi system and partition 1 which means the first active partition on that hard drive.

This could all be a little different depending on how your system is set up.

So, rather than get off on all kinds of stuff, why don't you list the contents of your boot.ini file, and also list how your system is set up RIGHT NOW, and exactly what you want to change.

In other words, are your two hard drives set up on IDE Controller number 1?

Here's a page that tells you more about boot.ini and what everything means in it:

Boot.ini explained

Ok, that's boot.ini. That will have to be edited to reflect the new drive configuration is what I'm getting at with all of this. It's a read-only file, by the way, so you have to right-click on it, choose properties, and uncheck read-only. It's located in your C:\ folder. In order to even see the file, you have to have your folder options set to display hidden files and not hide file extensions.

There are some other boot files that need to be moved, too, to your "new" c: drive:

boot.ini
ntloader
ntdetect.com

and possibly

ntbootdd.sys
cmdldr (if you have these 2 files)

All of these are located in the C: folder, with autoexec.bat and config.sys and bootsect.dos, for example.

They will have to be moved to the C:\ folder when you remove the other drive and the second drive now becomes C:.

But that's something to think about, too. You'll be able to change boot.ini and move these files quickly and easily enough. But all of your installed programs in Windows 2000 probably think they were installed on Drive D vs Drive C, so you might have all manner of errors when trying to run programs because you'll get "can't find file so and so" because it has pointers in the registry to drive D: vs. Drive C:.

I'd get a program like Norton Utilities 2001 and run Windoctor AFTER you change the drives and change boot.ini and move those files. It will tell you that you've got some wrong pointers in your registry for programs and allow you to repair them.

All in all, as you can see, it might be an easier task to just start fresh with a new install.
 

FiDo14DiDo

Senior member
Apr 7, 2000
603
0
0
Mucho gracias!!!!


Here's what I got Slik:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect
C:\="Microsoft Windows"

It is showing disk(0) because I have the WIN2K drive set up as master but I set up the bios to boot from the slave (Win98sE drive). Both drives are on IDE channel 0

Also, I have a IWill KK266 KT133A chipset. Not sure if that makes a difference since I my rdisk comes up as "1" rather than 0.

EDIT: What files are needed in the root directory?? I have so far:
boot.ini
boot.prv
bootlog.txt
command.com
ntdetect.com
ntldr
pagefile.sys

Do I need io.sys or msdos.sys because it still tells me boot disk failure.
 

Slikkster

Diamond Member
Apr 29, 2000
3,141
0
0
I'm not clear on something. Was Windows 2000 ALWAYS the master drive in this arrangement, or is it now and that's why you're getting the errors? In other words, you mentioned Win98 was what you installed Win2000 from, so Win98 had to be on the first drive. Now, you want to pull that drive out but Windows 2000 won't load now.

I would change the rdisk value from 1 to 0. It's an rdisk value because you're chipset's controllers are actually scsi-based, like my Promise Ultra card. So, anyway, right now it's showing rdisk 1 which means it's looking for Windows 2000 on your second drive. You need to set rdisk (0) so it looks for it on the c:\ or first drive.

To change boot.ini, remember, right click on the filename, choose properties, and then uncheck read-only.

change the rdisk value both places it appears, in the Default=...lind and also just the line by itself.

Let us know...

You need

boot.ini
ntldr
ntdetect.com

on your c:\ drive root folder.

You shouldn't need pagefile.sys, as it should create a new one, but if any problems, move it over.
 

FiDo14DiDo

Senior member
Apr 7, 2000
603
0
0
I gave up! I just reformatted the drive and installed a fresh WIN2K. Thanks for all the info Slikkster...will help in the future.