Win2K 60Hz problem and refreshforce

Goi

Diamond Member
Oct 10, 1999
6,751
4
91
Hi guys...

Only recently have I noticed that I'm stuck at 60Hz on Win2K when playing games...doh, I guess I must be slow.
Anyway, so I downloaded refreshforce, and ran it, ok it seemed to work, at least the program doesn't display any error message when I applied the new settings.

So I loaded up Q3A at my normal 800x600 resolution, and check the the refresh rate with my monitor's OSD, doh its still 60Hz. Have I done anything wrong? The documentation of refreshforce says to ensure that "Hide modes monitor can't display" is checked, well that option is grayed out for me, does that make any difference? I tried reverting to 640x480@60Hz desktop resolution but that box is still grayed out.

btw here are my relevant system specs:
3dfx Voodoo3 3000 16MB
Nokia 445Xpro 21" monitor
Windows 2000 Professional SP3
1600x1200@85Hz desktop resolution
800x600 game resolution(stuck at 60Hz though)

Any ideas? Thanks!
 

Rucsac

Member
Apr 29, 2002
38
0
0
You tried running Direct-X on your PC and altering in there?

[Hard drive]\Program Files\Directx\setup

Run DxDiag (Shortcut)

Then go to the end tab "More Help" and OVERWRITE refresh, try that sir......

Good luck.....

Wain
 

Goi

Diamond Member
Oct 10, 1999
6,751
4
91
Well, I didn't try that, but like I said, I'm having problems with Q3A which is an OpenGL game. Does the dxdiag really help then?

Anyway, I downloaded RefreshLock, and that worked, once I got it not to set my refresh rate to 100Hz at 1600x1200. Somehow it thinks my Nokia 445XPro is capable of that when it isn't. Took me 2 reboots to set it manually. However, RefreshLock needs to be running all the time, and AFAIK Refreshforce is supposed to be run just once and never again, which I'd prefer, since I have a lot of programs running in the background already.
 

Smilin

Diamond Member
Mar 4, 2002
7,357
0
0

For quake 3 here's your guaranteed fix. From the quake console type the following:

/r_displayrefresh X
/vid_restart

Where X is the refresh rate you want. WARNING: There is NO sanity check on this. It will let you set any refresh rate you want regardless of your monitor capabilities.

If you want this change to be permanent put "set r_displayrefresh X" in your autoexec.cfg file in your quake directory. You can also put "+set r_displayrefresh X" at the end of the command line in your quake 3 shortcut.

Can't really help with other apps. It's an annoying bug in the Windows NT 5.x OS. There are various utils out there but as you've seen some work, some don't.

 

Goi

Diamond Member
Oct 10, 1999
6,751
4
91
guess what? r_displayrefresh, the "gauranteed fix" didn't work :(

Anyway, as I've mentioned, the only thing that works so far is RefreshLock...I've already tried that, but thanks for mentioning it Mem. The problem with that is that its memory resident, and takes up like 3-4MB of memory. AFAIK refresh force, if its supposed to work, runs just once and never again...?
 

Goi

Diamond Member
Oct 10, 1999
6,751
4
91
Hmmn, for some reason I think it has something to do with the fact that my "Hide modes that this monitor cannot display" checkbox is unchecked and gray. Also, in place of the "Monitor Type" description in my Monitor menu, I have a white selection box with my "Nokia 445Xpro" monitor selected as an only choice. Normally, "Monitor Type" should be of a gray background much like the rest of the menu rather than a selection box. I've checked this with 2 other computers in my house, both running the same Win2K SP3 and this is the case, only mine shows these 2 anamolies...any idea how to correct this, and if this is causing the 60Hz thing?
 

ASK THE COMMUNITY