Win2000 = Video Card Hell

brian_riendeau

Platinum Member
Oct 15, 1999
2,256
0
0
I have a long standing problem that has been preventing me from using Win2000 as a development platform for C++ like I want. I first had this problem back a few weeks ago trying to get Win2000 going for the first time with my GTS card. Now the problem is occurung with my Radeon too :( I would REALLY appreciate it if anyone could help me out in correcting this.

No matter what I do with either video card, whenever I reboot Win2000, I am back to VGA display mode. I have tried three BIOSes for my Soyo 6BA+III and all of the BIOS setting I could think of. I have tried installing the drivers different ways as well. When I run the auto setup on my ATI CD is says that I do not even have a Radeon card installed. Up to now I have probably spent 20+ hours trying to fix this to no avail. Anyone have some good ideas? Do I need a new motherboard? Thanks.
 

Dude1

Junior Member
Oct 5, 2000
5
0
0
May not be your problem but , Win2k professional requires a ACPI compliant mainboard. Had similar problem with GTS2 64meg card & older mainboard. Gave me an excuse to buy a new Mainboard. If this is not your problem check to see if you have the correct miniport driver. good luck
 

brian_riendeau

Platinum Member
Oct 15, 1999
2,256
0
0
My Soyo 6BA+III is about a year old and uses the BX chipset. I *think* my board is ACPI compliant but I am not sure, I will look into it...
 

Zoltarc

Senior member
Sep 11, 2000
436
0
0
I'm not sure if this will help you but it worked for me.

Disable P&P OS and ACPI in your BIOS.

Reboot. Go to Control Panel - Hardware and double click on My Computer in the hardware manager.

You'll see ACPI - get into its properties and click to install another driver. When prompted, look under the Microsoft section and install the "Standard PC" driver.

Reboot. At this point Win2k will try and reinstall all devices on your system so install any drivers you are prompted for (have them all handy) and reboot. Finalise any drivers you may be prompted for on the 2nd boot and reboot again.

With all your drivers re-installed, take a look in hardware manager - and every device should have its own IRQ.

Be warned that this method is discouraged by Microsoft - see the note at the bottom of this Knowledge Base article.

You could try disabling AGP4X in the BIOS too. This sometimes works
 

brian_riendeau

Platinum Member
Oct 15, 1999
2,256
0
0
I tried that Zoltarc and thought it just might work. Once I disable ACPI in the BIOS Win2000 will not load. After the inital Win2000 startup screen (the black and white one with the status bar at the bottom) my computer resets itself. Then I tried going into Win2000 and removing anything that said "ACPI" on it from the Device Manager but I rebooted to the same problem where my computer resets itself after the first Win2000 startup screen.

On a side not it is a good thing this Radeon is working out well in WinME. I traded my GTS for it primarily because I thought it would fix the Win2000 problem.