• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Win10 stuck in endless "Preparing automatic repair" loop

suszterpatt

Senior member
Jun 17, 2005
927
1
81
Quick rundown of the situation:

- Oldish PC with 2 HDDs, one of them has been showing signs of failure recently

- Earlier today it still worked, then I went to shut it off and got a BSOD (something about videoport.sys, doesn't sound relevant because there are no video problems otherwise)

- I connected a new SSD (to replace both drives once I migrated my data over)

- Now Win10 doesn't boot, just goes into "Preparing automatic repair", fails to repair anything

- SrtTrail.txt stops at "Disk metadata test", which "completed successfully" with error code 0x32. No idea what that means.

- I can run a command prompt in WinPE but do litte else



Things I have tried:

- Disconnected the SSD, reset BIOS by removing the battery from the motherboard

- Going to Startup Settings and hitting Restart doesn't present me with the startup menu, it just goes to "preparing automatic repair" again. So I can't boot into safe mode.

- chkdsk apparently fixed a bunch of errors on one of the drives, now it reports no errors on either drive

- sfc /scannow /offbootdir /offwindir fails with "windows resource protection could not start the repair service", even if I do "net start trustedinstaller" beforehand (which says it started the service successfully)

- bootrec /rebuildbcd shows 0 installations, but if I boot to WinPE using a Win10 boot CD, it recognizes the Win10 install on the machine. bootrec /fixmbr and /fixboot did not help either

- System restore fails with 0x81000204, which also sounds like HD failure/data corruption of some kind

- Copied the contents of %windir%\config\RegBack\ to %windir%\config

- Probably some more stuff that I'm forgetting right now (I've been frantically googling for the past couple hours)



Things I am reluctant to try:

- "Go back to previous version". The machine originally had Win7 on it, and decided to automatically update itself to Win10 one night. This was some time ago, I'm not sure why this option is still there, and I don't want to risk not being able to upgrade again.

- "Reset this PC". Since I don't have a Win10 install disk, I don't know if this could help at all.

- Cloning the drive from the recovery command prompt. Not even sure if it's possible, and I might end up cloning the OS in its corrupted state.


What else can I try to get the system up and running again?
 

daveybrat

Elite Member
Super Moderator
Jan 31, 2000
5,462
714
126
Most of the computers i work on with that Startup Repair Loop syndrome are caused by a failing hard drive. I test every drive first before i go any further.
 

suszterpatt

Senior member
Jun 17, 2005
927
1
81
Most of the computers i work on with that Startup Repair Loop syndrome are caused by a failing hard drive. I test every drive first before i go any further.
The HDD Windows is on is definitely on its way out, that's part of the reason for the new SSD. When I first ran chkdsk, it fixed tons of errors, which apparently resulted in a bunch of orphaned files as well. I suspect some system files got mangled in the process, but I can't run sfc /scannow to make sure. :\ I have now tried deleting C:\Boot\Boot and recreating it with bootrec /rebuildbcd, no luck.

You don't need a Windows 10 install disk when you select "reset this PC".

But you can get a current Windows 10 install disk and see if you can repair anything by booting to it:

https://www.microsoft.com/en-us/software-download/windows10
I tried this, made a bootable USB drive. It boots, offers to install Windows or Repair the computer. Clicking repair just takes me back to the same recovery environment. >_<

I also tried Reset this PC, but that also fails halfway through with an error (doesn't say what error) and doesn't end up changing anything.

I also made a bootable DVD from this link: https://www.tenforums.com/software-apps/27180-windows-10-recovery-tools-bootable-rescue-disk.html#post434481 . All the recovery tools fail the same way though, but at least I was able to extract the product key. I'm thinking at this point I should just do a fresh install on the SSD.
 

PliotronX

Diamond Member
Oct 17, 1999
8,883
107
106
With a usb installer or HDD with isos on it (zalman iso jukebox I call it), it takes 10 minutes to fully install a fresh windows which is why I will back up (if data is on the system partition) and wipe it out before spending too much time attempting to salvage. Reformat that guy, its always better than copying over to a new SSD anyway :D

Bonus: you don't need to worry about the windows key since it had been activated on that motherboard already.
 

VirtualLarry

No Lifer
Aug 25, 2001
52,286
7,094
126
I had something similar happen to me just the other night. It was a H110 Asus board with a Skylake Pentium dual-core, and a "Radeon R3" SSD. (Not mfged by AMD, only with a licensed name.) Anyways, it was a TLC SSD, that hadn't been used for nearly a year. It wasn't reading or booting right, and sometimes the BIOS would even fail to detect it.

I had to boot Linux Mint on a USB, and hot-swap it with another known-good SSD, to Secure Erase it.

I then re-installed Windows 10 onto it. Some things were ... really slow, after booting the fresh Win10. But eventually, they worked themselves out, and it now seems to be working OK. Kind of strange, really, as those were very fast SATA SSDs originally.
 

ASK THE COMMUNITY