• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question Win10 installer crashes instantly on ancient i7 920-based PC

FaaR

Golden Member
Dec 28, 2007
1,057
408
136
I've got a geriatric PC from - I think - 2008, based on an ASUS Rampage II Gene motherboard, Core i7 920 CPU, 12GB RAM and - currently - an AMD R9 390X GPU, but also tried my good olfashioned NV 8800GTX boards. BIOS installed is the last/final version released by ASUS. System drive is an Intel X-25E 60GB SSD.

Win10 installer, both spring and autumn 2019 versions, show the win10 flag/logo when starting up, and then...nothing. It just sits there frozen, forever. Keyboard dead, mouse dead, everything dead, completely stone hung.

Doesn't matter if I try to update the current install through windows update, or try a clean install by booting up from a USB stick and the installer auto-running off of it, it just hangs straight away in both cases. And I've tried multiple times, it never changes.

The computer already runs win10 pro, it's probably autumn 2018 version, but I'm not 100% there. Could be spring version too, it was quite a while now since I used this PC even casually. :p So win10 does run on it, it's just these later incarnations where it goes t*ts up for some bizarro reason before even finishing loading the installer GUI...

Anyone has any idea what I could do to coax this thing into updating? It would be nice to have this oldtimer made current, to keep around as a backup PC if ever needed.

Any help muchly appreciated!
 

VirtualLarry

No Lifer
Aug 25, 2001
50,430
6,030
126
Are you on a SATA SSD or (Gasp) HDD? Might want to do a surface / error-scan on it, and check SMART info with CrystalDiskInfo. Maybe it's going bad, and causing the installer to hang, when attempting to read/write a bad spot.

I don't think that there are any processor opcode incompatibilities with Nehalem CPUs, as Win10 will run on previous-gen Core2 CPUs just fine, AFAIK, still.

How old is the PSU? Have you checked for swollen caps on the mobo?
 

mikeymikec

Lifer
May 19, 2011
14,280
4,333
136
I tried to install Win10 on a Nehalem based system recently and had to switch off VT-d before more recent versions of Windows 10 would install. 1607 installed fine, not that that helped much.
 

ASK THE COMMUNITY