Win XP Control Panel Problem

Sep 23, 2004
25
0
0
Running XP Pro SP2. I have a strange problem that has surfaced and I dont know how to fix it. When I click on the 'Add/ Remove Program' (in the control panel), Windows displays the Add/ Remove applet, but takes forever to display the list of programs. It says, "Please wait while windows populates the window."

So in another words, none of the install programs are displayed and seems to take forever for the list to populate. Actually, it just hangs on that message.

Does anyone have any experience with this?
 

Bluestealth

Senior member
Jul 5, 2004
434
0
0
Mine takes forever to come up too, its likely searching reg enteries or something like that... does yours not come up at all?
 
Sep 23, 2004
25
0
0
Originally posted by: Bluestealth
Mine takes forever to come up too, its likely searching reg enteries or something like that... does yours not come up at all?

Well here's the thing. As referenced in my message above, it seems to hang forever on that message. So earlier tonight I let it sit there for a while while I went off to do my dishes hoping that it would populate eventually. Some 15-20 min later, it was still stuck on that message.

I know the list does take a few minutes to populate because i've got such an old PC and dozens of programs installed, but it has never taken this long.
 

AMCRambler

Diamond Member
Jan 23, 2001
7,701
26
91
It sounds like you might have a bad key in your installed programs registry key. If you're comfortable with registry editor, open it up and check out the folders under <HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\>. Each one of those folders contains the install information that gets listed when you open up Add/Remove programs. If there are any that no longer exist or don't look like they belong there delete them out. I found this when I had some software where the uninstall would not work and I had to remove them manually. To get them out of the add/remove programs list once I deleted their files, I had to go into this key and delete the entries for it. I'm thinking one of the entries is corrupt there on your machine and as a result the Add/Remove programs can't generate it's list.
 
Sep 23, 2004
25
0
0
Originally posted by: dBTelos
Try running windows defragmenter, or whatever defragmenter you use. Run a chkdsk also. Then you could try using a reg. cleaner to speed things up a bit.

My hard drive is defragged on a weekly basis so that is not the problem. Besides even it were badly defragged, 20 min plus is a ridiculous amount of time to wait for the list to populate. 20 min is just the beginning - it hangs forever on that message. I already use a registry cleaner but thanks for the suggestions.
 
Sep 23, 2004
25
0
0
Originally posted by: AMCRambler
It sounds like you might have a bad key in your installed programs registry key.... I'm thinking one of the entries is corrupt there on your machine and as a result the Add/Remove programs can't generate it's list.

I also think that it's a corrupt key or setting in the registry. Before I posted my question I looked in the registry (under the same key you noted above) - and there were several CLSID keys listed. I have no idea which one to target or suspect that is causing the problem so I'm not touching any of those keys unless I know exactly which one to modify. What I really need is a registry expert that knows exactly which key or setting to modify. hmm.......
 

bsobel

Moderator Emeritus<br>Elite Member
Dec 9, 2001
13,346
0
0
Originally posted by: dBTelos
Try running windows defragmenter, or whatever defragmenter you use.

Oh please, how in the world do you think this is defrag related :roll:

Then you could try using a reg. cleaner to speed things up a bit. I use and recommend reg seeker, below, it makes a backup and works very well and it is a stand alone also.

Better advice, sounds like a corrupt hive.