Win 7 won't remember wireless network key

Discussion in 'Networking' started by Nessism, Jan 25, 2013.

  1. Nessism

    Nessism Golden Member

    Joined:
    Dec 2, 1999
    Messages:
    1,610
    Likes Received:
    0
    Used to remember but not any longer. Need to type the key every time I try to access the internet.

    Box to remember password is checked.
    Tried deleting the connection and entering new but that doesn't work either.

    Any ideas?
     
  2. Smoove910

    Smoove910 Golden Member

    Joined:
    Aug 2, 2006
    Messages:
    1,184
    Likes Received:
    0
    if you are on Windows 7, while you are connected, click the Network Bars in the lower right-hand corner of your screen:

    [​IMG]

    A box will come up that shows all the available networks in your area... right click the one you are connected to and click on 'properties'.

    Now click on the 'connections' tab, and ensure the 'connect automatically when this network is in range' box:

    [​IMG]
     
  3. Nessism

    Nessism Golden Member

    Joined:
    Dec 2, 1999
    Messages:
    1,610
    Likes Received:
    0
    Thanks but already did this. Doesn't work.
     
  4. nickbits

    nickbits Diamond Member

    Joined:
    Mar 10, 2008
    Messages:
    4,125
    Likes Received:
    0
    Forget the network and reconnect. Could try changing ssid. Or reinstall windows.
     
  5. Smoove910

    Smoove910 Golden Member

    Joined:
    Aug 2, 2006
    Messages:
    1,184
    Likes Received:
    0
    alrighty, try this:

    open search, type "services.msc" open services.
    Scroll down to "wlan auto config" right click, stop the service.

    Navigate to
    "C: \ProgramData\Microsoft\Wlansvc\ delete everything in this folder leaving only a folder called "profiles" delete everything in the "profiles" folder except for a folder called "interfaces" delete everything in the "interfaces" folder)

    Restart "wlan auto config" connect to your wireless network, enter
    your passkey, (ensure the connect automaticly box is checked)

    Restart your computer job done, your computer will now connect to your wireless network automaticly on boot.
     
  6. Nessism

    Nessism Golden Member

    Joined:
    Dec 2, 1999
    Messages:
    1,610
    Likes Received:
    0

    Don't have a folder called "ProgramData".

    Hidden?

    Not sure what to do.
     
    #6 Nessism, Jan 25, 2013
    Last edited: Jan 25, 2013
  7. Smoove910

    Smoove910 Golden Member

    Joined:
    Aug 2, 2006
    Messages:
    1,184
    Likes Received:
    0
    yup, it's hidden

    Open Folder Options by clicking the Start button , clicking Control Panel, clicking Appearance and Personalization, and then clicking Folder Options.

    Click the View tab.

    Under Advanced settings, click Show hidden files and folders, and then click OK.
     
  8. Nessism

    Nessism Golden Member

    Joined:
    Dec 2, 1999
    Messages:
    1,610
    Likes Received:
    0
    Okay, found it.

    Followed your instructions and it didn't work.

    Shut down "wlan auto config"

    Deleted all the stuff in the "interfaces" folder. The profiles folder didn't have anything in it other than the interfaces folder.

    Restarted "wlan auto config".

    Rebooted, typed password to get on the internet to confirm it worked.

    Rebooted again and system didn't remember password.:(

    Thanks so much for the help so far. Back where I started though I'm afraid.
     
  9. Smoove910

    Smoove910 Golden Member

    Joined:
    Aug 2, 2006
    Messages:
    1,184
    Likes Received:
    0
  10. JackMDS

    JackMDS Super Moderator<BR>Elite Member
    Super Moderator

    Joined:
    Oct 25, 1999
    Messages:
    27,757
    Likes Received:
    4
    Look at the Wireless Manger Right click on a connection there is menu concerning the Users that if checked incorrectly it might cause the issue.


    :cool:
     
    #10 JackMDS, Jan 26, 2013
    Last edited: Jan 26, 2013
  11. Nessism

    Nessism Golden Member

    Joined:
    Dec 2, 1999
    Messages:
    1,610
    Likes Received:
    0
    Think I got it.

    Went though Smoove910's instructions again, AND uninstalled the wireless adapter's software. Rebooted and this time only installed the adapters driver, not the other software junk. I think there was a software conflict because now the system remembers the password.

    Thanks for the help.:)
     
  12. Tristram

    Tristram Junior Member

    Joined:
    May 12, 2013
    Messages:
    1
    Likes Received:
    0
    Thank you Smoove910 for your advice on wiping out everything in the Interfaces folder, then trying again. I was having exactly the same problem, having to key in the wifi password each time. I did as you described, then rebooted and it fixed my problem. Nice work!