Question Why WD 2tb blue HDD keeps disconnecting randomly ?

bhardwaj

Junior Member
Dec 10, 2021
5
0
6
system specs :
Ryzen 2700
8 x 2 Crucial Callistix 2999 MHz
b450m pro m2 MSI
240gb wd green boot drive
2TB WD BLUE HDD
CoolerMaster MWE 650
build is around 1 year old.
Windows 11
BIOS Version/Date American Megatrends Inc. A.B0, 27-11-2020 <== this info source is windows' "system information".
BIOS version from BIOS settings => E7B84AMS.AB0 , i think this is older bios and now updates are available . but i'm not updating for now.

The WD Blue HDD keeps disconnecting randomly even when im using it or not using it. I think it started since I first installed windows 11 beta to try it out and I again installed windows 10 because win 11 did not work as expected , even though i have clean installed windows 10 and reset the Motherboard BIOS . the problem still persists. i have then replaced the HDD from the service centre (got a new one), it was still in warranty. still the problem is there . what can be the problem .?! the power in my area is not so stable , there is voltage fluctuations , I have changed the SATA cable and tried different motherboard SATA ports but the no luck. if i plug in other HDDs (even with the same cable and SATA port) it does not do this disconnecting thing . what can be the problem ?!

could this be the data stored inside the HDD ?

this doesnt happen with other HDDs that I plug in the system. only this one .

thank you !
 

deustroop

Golden Member
Dec 12, 2010
1,857
310
136
Give an example of this " disconnects" activity. Is the drive shown in Disk Management ? Can you post a pic of DM before and after "disconnects" ?
You say i'm not updating for now --perhaps rethink that.
 

bhardwaj

Junior Member
Dec 10, 2021
5
0
6
by disconnecting i mean , it when you plug in the drive and unplug it that kind of situation, it disappears from the system and reappear after 1-4 sec, and most of the tiemes restarting the system solves this. And if you think i should upgrade the bios then im upgrading now . this problem occurs very randomly , some times it doesnt happen or sometimes it just doesnt let me use the HDD(keeps disconnecting and reconnecting).

sorry for late reply
THANK YOU!
 

mikeymikec

Lifer
May 19, 2011
15,227
5,377
136
I'd go into Event Viewer, Windows logs > system log, look around the time of one of these incidents and see what it says.

Have you also heard the drive spinning down when this has happened?
 

bhardwaj

Junior Member
Dec 10, 2021
5
0
6
I'd go into Event Viewer, Windows logs > system log, look around the time of one of these incidents and see what it says.

Have you also heard the drive spinning down when this has happened?
yes i hear that weird noise of drive connecting and disconnecting every time it does this.
 

mikeymikec

Lifer
May 19, 2011
15,227
5,377
136
i see an error , can you help me verify that its the same 2tb hdd?
That particular error entry is citing harddisk0, and as your SSD is the boot drive, I expect it to be talking about that (though there are exceptions to the 'harddisk0 is always the boot drive' rule). Try using a program like CrystalDiskInfo to check each drive's SMART data?
 

bhardwaj

Junior Member
Dec 10, 2021
5
0
6
there is caution. i have replaced the HDD from the service center , but it looks like they gave me the same HDD. ;), its still in warranty though.
 

Attachments

Last edited:

ASK THE COMMUNITY