Why do I keep losing my IP address and my DNS servers?

Discussion in 'Networking' started by JohnBlack007, Jul 20, 2001.

  1. JohnBlack007

    JohnBlack007 Banned

    Joined:
    Jul 12, 2001
    Messages:
    110
    Likes Received:
    0
    I have two pc's connected to a cable modem using a linksys switch. For some reason every few hours or so my IP address will change to an IP autoconfiguration address in WINIPCFG and I'll lose my DNS servers. Usually I can just fix this by pressing the renew button, but this is getting annoying. Anyone ever have this problem and know what's up? Thanks.
     
  2. Shadow07

    Shadow07 Golden Member

    Joined:
    Oct 3, 2000
    Messages:
    1,200
    Likes Received:
    0
    Is the Linksys a Broadband Router, or truely a switch? Are the IP addresses public (coming from your ISP) or private with your own internal DHCP server?

    Also, check the Lease Time when you run WINIPCFG /ALL. Check to see that the time is not hours, but days. If the Lease Time is set to hours, then you have a problem. Well, a problem if your DHCP server is your own. If not, then your ISP has set the Lease Time too low. I would call your ISP and find out.
     
  3. JohnBlack007

    JohnBlack007 Banned

    Joined:
    Jul 12, 2001
    Messages:
    110
    Likes Received:
    0
    i have the switch that comes with the linksys switched network in a box. the lease expires every 3 hours. i'm going to try hooking up one computer to the cable modem for a day and see if this continues.
     
  4. Shadow07

    Shadow07 Golden Member

    Joined:
    Oct 3, 2000
    Messages:
    1,200
    Likes Received:
    0
    Then, you should contact your ISP and ask them why the lease expiration is so low. Connecting it directly to your cable router(modem) won't do anything to improve this.

    Contact your ISP and ask them why.