What's a good card for my Dell 545s?

stuman74

Senior member
Oct 26, 1999
874
1
81
I have on order a Dell 545s slim tower and would like to get a newer video card for it. It comes with the onboard Intel G33.

I am planning to have this in my family room connected to my LCD HDTV via HDMI so I basically need a decent low-profile card with HDMI that does not consume too much power since the power supply is only 250 W.

I have been eyeing this ASUS EAH4350 card. Is it good enough for what I need?
http://www.asus.com/product.aspx?P_ID=sikN0jmrkCWmk1oD

I'm not a big gamer, but I do want to be able to watch HD videos and stream HD video (like from MLB.TV) through this thing since it will be connected via ethernet to my router (which gets 20 Mb download via Comcast).

Please let me know any other good suggestions/recommendations. Thanks!
 

v8envy

Platinum Member
Sep 7, 2002
2,720
0
0
What do you need a GPU for that your current video card doesn't handle? The 4350 should be significantly less powerful than the 8600GT you have now. Even an 8400GT can do 1080p playback since that is handled in fixed function decoding hardware and not shaders. Not all web video clients support hardware accelerated playback anyway.

The hot deals $16 AR GT210 may be the card you're looking for; it should work fine in a 250 watt PSU dell.
 

stuman74

Senior member
Oct 26, 1999
874
1
81
What do you need a GPU for that your current video card doesn't handle? The 4350 should be significantly less powerful than the 8600GT you have now. Even an 8400GT can do 1080p playback since that is handled in fixed function decoding hardware and not shaders. Not all web video clients support hardware accelerated playback anyway.

The hot deals $16 AR GT210 may be the card you're looking for; it should work fine in a 250 watt PSU dell.
It's not for my Dell 530 in my sig but rather a new Dell 545s that I ordered. It will be connected to my HDTV.

I do know that with the rig in my sig, when I ran some videos or TV from my Hauppauge tuner card, it would stutter sometimes with HD video when I connected directly to the onboard G33 chip (and didn't use the GeForce card).
 

ASK THE COMMUNITY