what could cause a car to stop suddenly?

Discussion in 'The Garage' started by loki8481, Jul 4, 2011.

  1. loki8481

    loki8481 Lifer

    Joined:
    Feb 18, 2004
    Messages:
    42,559
    Likes Received:
    12
    so, I've had my car (mazda protege) for about 5 years now.

    in this time, I've had 4 incidents where the car has stopped suddenly and the engine died. while stopped, all the usual dashboard warning lights go on (check engine, oil, etc)... turning the car off and turning the ignition back on has worked immediately every time.

    I'm not sure if it's related or just sheer luck, but every time it's happened, I was in the midst of slowing to a stop anyways (it's happened twice in bumper to bumper traffic, and twice as I was approaching a stop sign/red light).

    and clue wtf could cause a problem so randomly and sporadically?
     
  2. Bartman39

    Bartman39 Super Moderator<br>Elite Member<br>For Sale/Trade<
    Super Moderator

    Joined:
    Jul 4, 2000
    Messages:
    8,547
    Likes Received:
    1
    Have you had it scanned for codes...? Possibly...

    Had an issue like that once before with an Izuzu car that turned out to be a defective ECU which was replaced by the dealer under warranty... Always happened when coming to stop and would just die so no power brakes or power steering which is not good...:thumbsdown:


    Common now help this guy...
     
    #2 Bartman39, Jul 4, 2011
    Last edited: Jul 4, 2011
  3. HAL9000

    HAL9000 Lifer

    Joined:
    Oct 17, 2010
    Messages:
    22,032
    Likes Received:
    1
  4. Doppel

    Doppel Lifer

    Joined:
    Feb 5, 2011
    Messages:
    13,313
    Likes Received:
    1
    Brakes!
     
  5. TakeNoPrisoners

    TakeNoPrisoners Platinum Member

    Joined:
    Jun 3, 2011
    Messages:
    2,597
    Likes Received:
    0
    Once when my PCM was damaged in my car it would do that. I would check that first.
     
  6. punjabiplaya

    punjabiplaya Diamond Member

    Joined:
    Nov 12, 2006
    Messages:
    3,495
    Likes Received:
    0
    +1 to check for codes

    see if you can replicate it

    has it had all its servicing done?
     
  7. dud

    dud Diamond Member

    Joined:
    Feb 18, 2001
    Messages:
    7,169
    Likes Received:
    1


    That's the way to intelligently contribute to the forums!!!

    Troll ...


    .
     
  8. 5150MyU

    5150MyU Senior member

    Joined:
    Jan 16, 2011
    Messages:
    327
    Likes Received:
    0
    Your idiot lights will come on every time the car dies-that is normal.
    Multiple things can cause what you describe-PCM,BCM,Fuel Pump,Relay,ASD Relay
    ETC-You need to be able to duplicate the problem when it is a no start.
    There may be a common problem with the protege-google may be your best answer.
     
  9. JechtShot

    JechtShot Senior member

    Joined:
    Feb 18, 2007
    Messages:
    326
    Likes Received:
    0
    Usually when that happens in a Honda, its usually a Defective Ignition Coil. Maybe test yours out.
     
  10. loki8481

    loki8481 Lifer

    Joined:
    Feb 18, 2004
    Messages:
    42,559
    Likes Received:
    12
    unfortunately, the problem doesn't seem replicatable. I've owned the car for ~5 years and the problem has occurred 4 times, all pretty evenly spaced out (I think the last time it happened was about a year and a half ago). but I drive the same way, in the same conditions, pretty much all the time.

    I've never taken it to a mechanic specifically for this problem, but it went in for a 50,000 mile tune-up/brake replacement last month and it's undergone DMV inspection twice without incident.
     
  11. T2urtle

    T2urtle Diamond Member

    Joined:
    Oct 18, 2004
    Messages:
    3,401
    Likes Received:
    0
    well there should always be a fault if the CEL is triggered. even if the problem isn't happening currently the fault is stored into history.

    your not giving us much. I can start guessing that a cam/crank sensor is intermittently failing but its pretty much a crap shoot.
     
  12. 5150MyU

    5150MyU Senior member

    Joined:
    Jan 16, 2011
    Messages:
    327
    Likes Received:
    0
    The most likely cause is the crank sensor but that is just a guess.Assuming it has one.-talk to a MAZADA tech-you are in a tough situation figureing out what is happening.
     
  13. Vadatajs

    Vadatajs Diamond Member

    Joined:
    Aug 28, 2001
    Messages:
    3,475
    Likes Received:
    0
    Does it sputter a little first? If so, check the EGR valve, they tend to get gummed up.
     
  14. HAL9000

    HAL9000 Lifer

    Joined:
    Oct 17, 2010
    Messages:
    22,032
    Likes Received:
    1
    It was as useful a contribution as this post.

    Edit: Please note, I meant no offence to the OP with this post.
     
    #14 HAL9000, Jul 4, 2011
    Last edited: Jul 4, 2011
  15. skyking

    skyking Lifer

    Joined:
    Nov 21, 2001
    Messages:
    17,539
    Likes Received:
    37
    that sounds like a loose electrical connection.