• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

weird vsync issue with Crysis 2 with gtx670

toyota

Lifer
Apr 15, 2001
12,957
1
0
if I start up the game I cant go past 50 fps with vsync on but if I turn it off and then turn in back on it will work properly. to be clear I am well over 60 fps in these areas so it is an issue with vsync just not working properly in Crysis 2 for me. if I alt tab after I have it working properly then again I have to turn off vsync and then turn it back on again. and this is on the 301.42 drivers.


on when starting game and cant go past 50 fps



off and see framerates are fine



back on and it works like it should

 

blackened23

Diamond Member
Jul 26, 2011
8,548
1
0
There's a driver bug which causes the GPU to throttle sometimes when you have vsync enabled. You will see stuttering usually in areas that are supposed to be 60 fps solid. It hasn't happened to me in crysis 2 but it definitely happens in D3 and WoW.

The only fix right now is to turn vsync off until the nvidia driver team fixes it

http://technewspedia.com/nvidia-promises-to-solve-the-stutter-bug-vsync-their-geforce-gtx-600-series/

So much for nvidias perfect drivers. Supposed to be fixed this month.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
no that has nothing to do with this case. my gpu throttling is not the issue here and again just turning vsync off and right back on will make it work. you can look right at the screenshots that show everything is clocked the same. plus I just saw a video from someone with a gtx560 ti getting it.

so after a little research it supposedly just a bug with game that happens at 1080p full screen. it is a little irritating to have to turn it off and right back on in the game but at least that fixes it.
 
Last edited:

blackened23

Diamond Member
Jul 26, 2011
8,548
1
0
no that has nothing to do with this case. my gpu throttling is not the issue here and again just turning vsync off and right back on will make it work. you can look right at the screenshots that show everything is clocked the same. plus I just saw a video from someone with a gtx560 ti getting it.

so after a little research it supposedly just a bug with game that happens at 1080p full screen. it is a little irritating to have to turn it off and right back on in the game but at least that fixes it.
Does toggling back and forth between fullscreen/windowed help? (instead of closing) Also, try putting "prefer maximum performance" in the control panel, i've heard that helps.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
Does toggling back and forth between fullscreen/windowed help? (instead of closing) Also, try putting "prefer maximum performance" in the control panel, i've heard that helps.
toggling will make it go to 60 in window but back to 50 in full screen. maximum performance is not the issue here either but I had already tried that. again its supposedly the engine that does this at 1080p full screen with vsync.

EDIT: and just checked the first Crysis and it does it too in DX10. turning it off and back on in the first game does not fix it though as it stays at 50 fps.
 
Last edited:

skipsneeky2

Diamond Member
May 21, 2011
5,035
0
71
Vsync is a broken useless pos feature right now with the most recent of drivers from nvidia,for sh*t and giggles i tested out BF2 my oldest game that supports sli and my dual gtx670s actually would dip to 54fps....while my previous card being a single gtx570 would hold 100fps all day long without dipping once.

BF3 is even worst i would dip into the 30s but when i use precision x and enable 80fps as a target framerate you can bet your ass i would stay above 64fps as a minimum.

Use precision x and enable 60fps as a target framerate or any other fps desired,vsync for me is broken in all my game titles.
 

Ferzerp

Diamond Member
Oct 12, 1999
6,435
106
106
Vsync is not a "broken useless pos feature right now". The behavior you guys are describing (other than toyota), I think is when the dynamic clocks are totally clocked too low. I'ev had a few games do that. You'll have vsync on, and the card will be humming along at 500-700Mhz and then hit a more complex spot and never increase clock. *That* is the broken part. vsync is fine.

Turning off vsync avoids it usually because it keeps the card working more and clocked up.

Also, setting that particular game's power saving mode to maximum performance (or whatever that setting is) will keep the clocks at at least the base clock and make that not happen.


Toyota has something different going on though, as you can see that his screenshots show the card is a full speed.

Is it possible that the refresh rate set when the game is running is only 50 fps? Windowed mode, you go back to your desktop refresh rate, and can get 60.
 

skipsneeky2

Diamond Member
May 21, 2011
5,035
0
71
Vsync is not a "broken useless pos feature right now". The behavior you guys are describing (other than toyota), I think is when the dynamic clocks are totally clocked too low. I'ev had a few games do that. You'll have vsync on, and the card will be humming along at 500-700Mhz and then hit a more complex spot and never increase clock. *That* is the broken part. vsync is fine.

Turning off vsync avoids it usually because it keeps the card working more and clocked up.

Also, setting that particular game's power saving mode to maximum performance (or whatever that setting is) will keep the clocks at at least the base clock and make that not happen.


Toyota has something different going on though, as you can see that his screenshots show the card is a full speed.

Is it possible that the refresh rate set when the game is running is only 50 fps? Windowed mode, you go back to your desktop refresh rate, and can get 60.
My card is at full speed when i get the unusual fps dips as well and if vsync isn't broken,something is but i do disable vsync but run precision x and target frame rate,i believe Toyota mentioned something about weird performance in his initial gtx670 upgrade thread and that is what had me installing precision x in the first place.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
again just to be clear, it turns out this particular issue has nothing to do with my card or drivers. its a Cryengine bug.
 

cmdrdredd

Lifer
Dec 12, 2001
26,867
286
126
A lot of people don't like adaptive vsync but have you tried that and does it exhibit the same issue?
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
A lot of people don't like adaptive vsync but have you tried that and does it exhibit the same issue?
it does not matter if its in game vsync, regular vsync from control panel or adaptive vsync from control panel. in DX11 for Crysis 2 or DX10 for Crysis 1 the game will think the monitor is at 50hz so it will cap the framerate at 50 no matter what type of vsync is used.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
hrm...well, let me try it and I'll see
its a game engine issue so you will get it too at 1080. there are a few other threads about it out there but most people never had the hardware to try and run vsync for the Crysis games.
 

skipsneeky2

Diamond Member
May 21, 2011
5,035
0
71
I still need to install Crysis 2,gonna look into this myself tonight and see if i pull the same issue,as i run dual gtx670 i would not know if its fair,but i could disable sli and report back and reenable it as well to see if the issue still arises.

Installing the game now.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
again it will happen for everybody at 1080 in DX11 for Crysis 2 and DX10 for Crysis. with Crysis 2 its a simple to fix though by turning vsync off and then back on. with the first game you have to do a crazy custom resolution. btw with HDMI it will usually go to 24hz at 1080. why Crytek cannot address this issue after all this time is ridiculous.
 

cmdrdredd

Lifer
Dec 12, 2001
26,867
286
126
Well, I'm not running 1080p so that's probably why the issue doesn't show for me. I never paid much attention, but I just ran fraps with the crysis 2 and it was at 60fps sometimes. Though you says 1920x1080, I'm at 1920x1200

edit just tried at 1920x1080 in the game. I set it manually. Here's a screenshot.




Oddly enough EVGA PrecisionX shows what you're describing. So now the question is...which is right? fraps or PrecisionX?

 
Last edited:

skipsneeky2

Diamond Member
May 21, 2011
5,035
0
71
I do believe i remember my game locking in at 50fps for me at 1080p as well,i never figured it out so i disabled vsync,soon enough this game should be installed so i could double confirm if this issue is still here.

Toyota does your fps lock in at 50fps even in multiplayer?Or just singleplayer?
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
I do believe i remember my game locking in at 50fps for me at 1080p as well,i never figured it out so i disabled vsync,soon enough this game should be installed so i could double confirm if this issue is still here.

Toyota does your fps lock in at 50fps even in multiplayer?Or just singleplayer?
I never played multi player
 

cmdrdredd

Lifer
Dec 12, 2001
26,867
286
126
well, per my above post fraps shows 60fps but PrecisionX shows 50fps lock. So I wonder...which is true? I don't think fraps is reporting correctly.
 

toyota

Lifer
Apr 15, 2001
12,957
1
0
well, per my above post fraps shows 60fps but PrecisionX shows 50fps lock. So I wonder...which is true? I don't think fraps is reporting correctly.
you might have an older FRAPS. I used FRAPS and Precision to make sure and they were both showing 50 fps.
 

cmdrdredd

Lifer
Dec 12, 2001
26,867
286
126
I got it from the main site. Either way, I think what you're seeing is real because when I switch between 1920x1200 and 1920x1080 I see it change.

If it's a bug in the engine I wonder how this slipped through? It's not as if 1920x1080 is a new resolution or anything.
 

skipsneeky2

Diamond Member
May 21, 2011
5,035
0
71
Ok so i installed the game and got it patched to 1.9,i log in and make sure vsync is enabled,at this time DX11 texture pack has not been downloaded or installed and its at 60fps.

I download and install the texture pack and it wants me to restart in order for the textures to be in effect,so as soon as the EXE runs i notice even in the menu its at 50fps,so its a issue with the DX11 texture pack.
 

ASK THE COMMUNITY