Weird Ubuntu + printer problem


May 19, 2011
I'm not a Linux expert by any stretch of the imagination. A customer wanted me to take a look at a problem despite me pointing all of this out (at every step of the way through this). Here's the timeline of events:

Last year, the customer asked me to set up the printer (rather than their son, not sure why, Epson WF-2510 btw). I did so successfully, on wifi no less, complete with the same 'auto find the printer on the network' feature that Epson has for its wifi printers with their own driver. I was quite surprised. I left two printers set up on the computer, one for wifi and one for USB just in case.

All was well. The other day, the customer asked her son to remove the other printer. After that, the wifi printer entry went from 'always works' to 'sometimes works'.

I visited for an unrelated reason for a relation of that customer shortly afterwards (at the same property), and the (this wifi printer) customer mentioned the issue in passing (not yet determined as "intermittent"). I power cycled the printer and it worked straight away.

Yesterday, the customer contacted me saying that the problem had re-occurred. Prefixing with my "I'm not an expert" disclaimer, I visited again. I tried a number of things, reinstalling cups, removing the epson printer package I installed last summer, having cups find the printer instead (which too resulted in the intermittent issue, but also resulted in a static IP entry in cups despite the printer not being configurable to a static IP!).

I ended up basically on the original configuration again (one wifi printer entry, one USB printer entry 'just in case', and briefed the customer), but I'm not confident that the problem is gone. For example, when the printer wouldn't respond via wifi, the printer was pingable, and I have no experience for knowing that it was a software or networking issue.

I wanted to take a look at the wifi router config, but a) I doubt that the son would be stupid enough to tinker with the wifi config remotely (I assume that's what he does because he doesn't live there), b) it didn't seem like a wifi issue per se, c) I didn't know the router admin password (it wasn't the default for that router).

One interesting point was that when the wifi print problem occurred, the wifi light was sometimes off on the printer. Pressing the 'wifi setup' light would make it come back on again in a split second, or aside from the light being off, power cycling the printer did the trick. I suppose the printer could coincidentally have developed a wifi issue, but it seems unlikely. In the course of troubleshooting (and hoping that I would get the option to set the printer to a static IP), I re-set-up the printer on the wifi network without any problems (except that the printer - WF-2510) has no option to set a static IP (which is unusual in my experience).

Furthermore, if I printed via wifi within say the first 10 minutes of switching the printer on, it worked fine. If I waited about ten minutes, then no printing would occur and the OS would inform me that there was an error connecting to the device.

Of course, I have no idea what the son actually did to make the second printer entry disappear in the first place, but the first printer appeared (at least through the GUI) to be set up in the same way as it had been originally - the printer's location/address was still set to 'localhost' (a quirk of Epson's custom network linkage to the printer seemingly, it was the same after I reinstalled the printer).

I didn't wait around to find out whether the printer worked after this 'maybe ten minutes of the printer being idle' problem, simply because I was all out of ideas at that point. If it had been a Windows + wifi printer problem, and if I had access to the router admin, I could have checked more things and usually failing everything, a static IP configuration on the printer would do the trick.

I've explained to the customer the nature of the situation so she's not expecting it to be completely fixed and she knows what to do if it doesn't work. I've also asked her to get the son to contact me and discuss the problem over e-mail in the hope of figuring out what might be going on with it.

I just wondered if anyone had any ideas here for what might have occurred.
Last edited:

Fallen Kell

Diamond Member
Oct 9, 1999
Without access to the wireless router, it will be next to impossible to tell what is going on. A short DHCP lease time might be happening with the printer getting a new IP...