Solved! Web Based vs Local Application Speed Tests

googalabosh

Junior Member
Jan 8, 2022
3
0
6
I've recently discovered a big issue between running a speed test via web based applications and local (downloaded) applications. I've tested many brands and have come up with the same results but I will focus on Ookla for this post.

When I run the tests online I get between 100 Mbps and 200 Mbps. But when I run the downloaded applications I easily get over 800 Mbps. I am paying for the 800 Mbps Xfinity (Comcast) plan.

I have tried different browsers as well as adjusting throttling speeds in Chrome. No matter what I do, I continue to get sub 200 Mbps with online speed testers.

I also tried resetting my TCP/IP settings with the following commands:
  • Type netsh winsock reset and press Enter.
  • Type netsh int ip reset and press Enter.
  • Type ipconfig /release and press Enter.
  • Type ipconfig /renew and press Enter.
  • Type ipconfig /flushdns and press Enter.
For a moment I thought this worked. After restarting my computer, I ran a test and was getting 800+ Mbps via the speedtest.net test but ran the test a few minutes later and it's back to 200 Mbps.

Attached are my Ookla screen shots for the web based and local applications. You can also see that I used the same server as well (Baltimore, MD Comcast).

Can anyone explain this to me?

My setup:
Comcast Cable
Arris G36 Gateway
TP-LINK 24 port gigabit Ethernet unmanaged switch
Trendnet 16 port unshielded patch panel
Cat 6 cable
Both computers are connected via ethernet
All tests completed via ethernet connect only

WebBased.png
LocalApp.png
 

Attachments

Last edited:

googalabosh

Junior Member
Jan 8, 2022
3
0
6
Maybe it's a content-blocker affecting the online version, either an ad-remover or your anti-virus, that whitelists the speedtesting app.

I take it that this is a less-than-current PC? Something around a 4th-Gen Intel (Haswell) PC?
DING DING DING!!!! You got it.

I have Bitdefender for my virus/firewall protection. I turned off the firewall and started getting 800+ numbers. I tested this multiple times with the firewall off and on and proved it definitely is my firewall.

How I fixed my BitDefender Firewall slowing down my browser speeds:

https://www.bitdefender.com/consumer/support/answer/3766/

1. Open the Bitdefender window.

2. Click Protection on the left-hand side.

3. In the Firewall panel, click the switch to turn on Firewall.

4. Click the Settings button on the Firewall pane.

5. In this window, select the Settings tab.

6. Go to Port scan protection and click the switch to turn it OFF.

7. Click Edit stealth settings next to Stealth Mode.

8. Set the switch corresponding to your network adapter to OFF, then press OK.

9. Now access the Network Adapters tab.

10. Click the box corresponding to your network adapter and select Home/Office.

11. Close Bitdefender, restart the PC, and check if the Internet connection speed has improved.
 
Last edited:

VirtualLarry

No Lifer
Aug 25, 2001
53,520
7,847
126
Same PC? Same wired connection? (You're not testing one wired and one wireless, right?)

Do you have an SSD, enough RAM, and a modern web browser? Are you using a browser-based free VPN service? Any torrents running on that PC? Anyone else using the PC at the same time?

Finally, are you fully up-to-date with Windows Updates?
 

googalabosh

Junior Member
Jan 8, 2022
3
0
6
Same PC? Same wired connection? (You're not testing one wired and one wireless, right?)

Do you have an SSD, enough RAM, and a modern web browser? Are you using a browser-based free VPN service? Any torrents running on that PC? Anyone else using the PC at the same time?

Finally, are you fully up-to-date with Windows Updates?
Same PC: Yes
Wired connection: Yes, only ethernet connections
SSD: Yes
RAM: 16 GB
Web Browser: I've used Chrome and Edge with same results
VPN: None
Torrents: None
Other users signed in: No
Windows updated: Yes

I also updated the original post to show my network set up.
 

daveybrat

Elite Member
Super Moderator
Jan 31, 2000
5,554
782
126
Try changing your DNS servers to Cloudflare's 1.1.1.1 and 1.0.0.1 or Google's 8.8.8.8 and 8.8.4.4
 

VirtualLarry

No Lifer
Aug 25, 2001
53,520
7,847
126
Is this a Dell, and/or do you have an AMD APU or dGPU? (Have you ever, since reformatting last?)

Because they install this supposedly stream-boosting software driver into the network stack, that actually greatly limits download speed, and can interfere with speed tests.

Barring that, if the limit that you see is often around 94-100Mbit/sec, perhaps your ethernet cable or port on router/switch is going bad.
 

VirtualLarry

No Lifer
Aug 25, 2001
53,520
7,847
126
Maybe it's a content-blocker affecting the online version, either an ad-remover or your anti-virus, that whitelists the speedtesting app.

I take it that this is a less-than-current PC? Something around a 4th-Gen Intel (Haswell) PC?
 

googalabosh

Junior Member
Jan 8, 2022
3
0
6
Maybe it's a content-blocker affecting the online version, either an ad-remover or your anti-virus, that whitelists the speedtesting app.

I take it that this is a less-than-current PC? Something around a 4th-Gen Intel (Haswell) PC?
DING DING DING!!!! You got it.

I have Bitdefender for my virus/firewall protection. I turned off the firewall and started getting 800+ numbers. I tested this multiple times with the firewall off and on and proved it definitely is my firewall.

How I fixed my BitDefender Firewall slowing down my browser speeds:

https://www.bitdefender.com/consumer/support/answer/3766/

1. Open the Bitdefender window.

2. Click Protection on the left-hand side.

3. In the Firewall panel, click the switch to turn on Firewall.

4. Click the Settings button on the Firewall pane.

5. In this window, select the Settings tab.

6. Go to Port scan protection and click the switch to turn it OFF.

7. Click Edit stealth settings next to Stealth Mode.

8. Set the switch corresponding to your network adapter to OFF, then press OK.

9. Now access the Network Adapters tab.

10. Click the box corresponding to your network adapter and select Home/Office.

11. Close Bitdefender, restart the PC, and check if the Internet connection speed has improved.
 
Last edited:

ch33zw1z

Lifer
Nov 4, 2004
35,279
14,403
146
That's funny, years ago I had problems with bit defender throttling my speeds. Dropped it tout suite
 

ASK THE COMMUNITY