Wake on LAN not working on my NUC

Discussion in 'Home Theater PCs' started by Dave3000, Jan 10, 2017.

  1. Dave3000

    Dave3000 Senior member

    Joined:
    Jan 10, 2011
    Messages:
    822
    Likes Received:
    1
    I'm having an issue with Wake on LAN not working on my NUC. It's an Intel NUC6i3SYH model. I'm using Windows 10 Home for the OS. I also could not get WOL to work in Linux. I was thinking about using my NUC as a Plex Media Server and using my Roku Ultra as a Plex client instead of using it as HTPC. I don't want to keep my NUC powered on 24/7 in order to use Plex Media Server. I want it to go to sleep after 1 hour of inactivity and only wake up when it receives a magic packet from my Roku Ultra through the network so that I don't have to manually go to my the server and wake it up each time I was to use Plex on my Roku Ultra. I have the latest network drivers installed on my NUC and still WOL won't work.
     
  2. Loading...

    Similar Threads - Wake working Forum Date
    Does the SiliconDust HDHomeRun CONNECT HDHR4-2US work with Windows 10? Home Theater PCs Dec 23, 2016
    Will this headphone setup work? Home Theater PCs Dec 11, 2015
    Creative Sound Blaster Z series not working with Tosklink/SPDIF Home Theater PCs Aug 4, 2015
    Openelec + chromebox, works on one tv but not the other Home Theater PCs Feb 5, 2015
    Bluetooth Keyboard/mousepad won't wake up HTPC Home Theater PCs Sep 11, 2013

  3. sinisterDei

    sinisterDei Senior member

    Joined:
    Jun 18, 2001
    Messages:
    260
    Likes Received:
    6
    Are you running Windows 10's firewall? If so, you may need to add the UDP port 9 exception to allow WOL to work.

    You'll also need to make sure that when the PC goes to sleep, that the network card isn't one of the things Windows turns off (it is by default).

    This is a decent-ish looking guide: http://winaero.com/blog/how-to-use-wake-on-lan-on-windows-10/
     
  4. Dave3000

    Dave3000 Senior member

    Joined:
    Jan 10, 2011
    Messages:
    822
    Likes Received:
    1
    I enabled UDP port 9 as you said and it still can't get WOL to work on this HTPC. I also followed the instructions in the article you post a link to and it did not help. On the last part of that article it mentions to gives you a command to enter on another PC to test the WOL on the PC you want to WOL, but I skipped that part because I want my Roku Ultra to wake up my HTPC when I launch Plex on it.
     
  5. Dave3000

    Dave3000 Senior member

    Joined:
    Jan 10, 2011
    Messages:
    822
    Likes Received:
    1
    Also there is no option for Magic Packet in the Advanced settings for my Network driver. I have Magic Packet showing only in the Power Management section of my Network driver.
     
  6. sinisterDei

    sinisterDei Senior member

    Joined:
    Jun 18, 2001
    Messages:
    260
    Likes Received:
    6
    Er, just to ask the question - does the Roku send the magic packet? I believe it'll need to do so in order to wake up the PC. WOL doesn't mean "wake up on ANY network activity" - it means "wake up when I get a WOL packet"
     
  7. Dave3000

    Dave3000 Senior member

    Joined:
    Jan 10, 2011
    Messages:
    822
    Likes Received:
    1
    When I launch Plex on my Roku Ultra, my main PC will wake up from sleep. So I know my Roku Ultra is sending a packet to my main PC to wake it up. I can't get this to work on my HTPC however. I also didn't have to do any configuring on my main PC to get WOL to work on it. My main PC has Windows 10 Professional and my HTPC has Home.
     
  8. sinisterDei

    sinisterDei Senior member

    Joined:
    Jun 18, 2001
    Messages:
    260
    Likes Received:
    6
    And you've gone into the BIOS on the NUC and enabled Wake-on-LAN there? I'm making an assumption here that the NUC even supports it. That's an option that may have been automatically enabled on your main PC that isn't enabled on the NUC.
     
  9. Dave3000

    Dave3000 Senior member

    Joined:
    Jan 10, 2011
    Messages:
    822
    Likes Received:
    1
    The BIOS in my NUC has a 3 Wake on Lan from s4/s5 options to choose from. One is Stay Off. The seoncd option is Power On -Normal Boot. The third option is Power On - PXE Boot. I tried all those options for Wake on LAN form s4/s5 and still Wake on LAN from sleep does not work. I have another option in the BIOS that is called Wake System from S5 but I kept that option unchecked since it's about waking up the PS from S5 using timers and mentions nothing about Wake on Lan for that option and that's not what I want.
     
  10. sinisterDei

    sinisterDei Senior member

    Joined:
    Jun 18, 2001
    Messages:
    260
    Likes Received:
    6
    Are you using the WiFi on the NUC or the wired network?

    Assuming the answer is wired - since WOL isn't supported on WiFi - you should check back in the Advanced tab and see if WOL options are available once WOL is enabled in the BIOS. Use the Power On - Normal Boot option.

    If none of that works, I'm out of ideas. I'll have a NUC in my possession on Thursday or Friday and I can do some testing with it then.