"Waiting for Origin to shut down" Whenever I shut down my PC?

futurefields

Diamond Member
Jun 2, 2012
6,471
32
91
Whenever I shut down my PC I get the prompt saying I need to wait for Origin to shut down. That doesn't seem normal to me. Does anybody else get that?
 

destrekor

Lifer
Nov 18, 2005
28,799
359
126
Sometimes running programs take a few moments to totally kill their running processes and let go of system resources.
I've rarely seen Origin hold up restart, usually it's Chrome for me (when I have about over a hundred tabs open). But that's also most likely because I typically force close Origin manually (right click - exit, from system tray).
 
Feb 4, 2009
34,556
15,775
136
only way I can exit Origin from windows 8.1 is ctr/alt/delete. Origin never closes and won't relaunch.
 

tential

Diamond Member
May 13, 2008
7,355
642
121
I finally figured it out. Your PC is actually waiting for Origin to shut down. Like as a service.
 
May 13, 2009
12,333
612
126
I actually disabled origin from starting when I boot up because it's so annoying. Between the pop up ads and not closing down it's basically bloatware.
 

compcons

Platinum Member
Oct 22, 2004
2,140
1,150
136
Thus is fairly recent for me too. Not sure if its a win7 update that caused it or an origin update. In wither case, its not right but I don't care enough to dig through logs/event viewer to fix it.
 

gorcorps

aka Brandon
Jul 18, 2004
30,737
448
126
funny, steam is usually the one stopping my computer from shutting down for me :p

It doesn't last long though
 

DeathReborn

Platinum Member
Oct 11, 2005
2,746
741
136
Steam & Raptr (yep that AMD app...) used to do that on my machines, but now I so rarely shut down it's a non issue.

Make a point of closing down things like Origin, Steam etc before you shut down, it's actually good practice to do so.
 

Red Hawk

Diamond Member
Jan 1, 2011
3,266
169
106
Both Steam and Origin tend to do this for me. I have them both set to not run on startup, and it's usually best to manually close out of them in the notification area of the taskbar before shutting down my PC.
 

irishScott

Lifer
Oct 10, 2006
21,568
3
0
Both Steam and Origin tend to do this for me. I have them both set to not run on startup, and it's usually best to manually close out of them in the notification area of the taskbar before shutting down my PC.

This, but in my case I don't mind. Both usually close down within 10 seconds and then the shutdown continues as normal. Granted I don't turn my computer off that often.
 

Dankk

Diamond Member
Jul 7, 2008
5,558
25
91
Never have this problem. I always manually exit Steam and Origin before shutting down Windows. I guess I'm weird.
 

Raduque

Lifer
Aug 22, 2004
13,141
138
106
On my Windows7 gaming desktop, it's usually the "This program is preventing windows from shutting down" dialog itself!
 

WhiplashGT

Junior Member
Mar 12, 2014
12
0
0
I usually play BF4 or Titanfall now right before I go to sleep and turn off the machine, so I do get the same message regarding Origin every time.

Is it bad to force the shut down?
 

JimScace

Junior Member
Jan 21, 2016
1
0
0
I have a laptop that supposed to shut down when closed but Origin is running and prevents this. Found in Origin Application Settings\Advanced Settings there is a box you check that "Shuts Down Origin when Game is Exited" problem solved.
 

DeadFred

Platinum Member
Jun 4, 2011
2,740
29
91
Origin and several other apps do this to me after moving to windows 10. It only takes a few seconds for them to close, so I dont see it as a big deal.
 

Red Hawk

Diamond Member
Jan 1, 2011
3,266
169
106
I have a laptop that supposed to shut down when closed but Origin is running and prevents this. Found in Origin Application Settings\Advanced Settings there is a box you check that "Shuts Down Origin when Game is Exited" problem solved.

Huh, you can do that? I actually didn't know. That's kind of convenient, thanks!
 

natto fire

Diamond Member
Jan 4, 2000
7,117
10
76
Steam does that for me as well. I have never installed Origin, but I usually just shut Steam down manually on the rare occasion I shut down over just using Sleep.