Voodoo3 Win2k Drivers question

OCNewbie

Diamond Member
Jul 18, 2000
7,603
24
81
Ok, if you go to 3dfx Drivers, and check for the latest WHQL drivers for the Voodoo3 on Win2k, you see that the latest version is listed as "1.04.00 (Supports DX8)", but when you click on the link, you download version 1.03.00. I'm just wondering if 1.04.00 is indeed out, and the link is bad, or is 1.03.00 the newest. Aaaaand, if 1.03.00 is the newest, is it DX8 comatible? If anyone knows any info please share with me, thanks! :)

Edit: One more thing, this might be a silly question... I notice that they DO have WHQL "1.04.00 (Supports DX8)" drivers for the Voodoo 4/5 PCI/AGP for Win2k, I'm guessing these drivers would not work at all with the Voodoo3, correct me if I'm wrong. They also have 1.03.00 for the V4/5 but they don't have the "Supports DX8" next to it, which makes me wonder about the V3's.
 

rbV5

Lifer
Dec 10, 2000
12,632
0
0
Before I swapped my V3 2000 for my new AIW Radeon, I used the beta 1.04(at that time)V5 drivers. The V4/5 drivers work well on the V3.
 

BFG10K

Lifer
Aug 14, 2000
22,709
2,971
126
I tried The V4/V5 drivers with my Voodoo 3 and they did appear to work for a while. However after a few days of use my system started having sleep related problems and random reboots.
 

kitkit201

Diamond Member
May 31, 2000
4,853
0
0
hey.. i think i found some 1.04 drivers from europe around the net.. try searching for it, im not sure where i found it though..