Voodoo Driver Problem


Senior member
Feb 28, 2000
I have a velocity 100 card that I've been using the V3 drivers for since the first day I got it. Ever since the March release of drivers from 3dfx, I haven't been able to install them on it anymore. It gets just past the point where it unpacks the files to the temp folder, starts the wininstall screen, then nothing. Tried to run the setup.exe in the unpacked temp folder, still nothing. Tried it in safe mode, tried totally uninstalling the s/w, etc, can't get it to go in. Any suggestions would be welcome.


Platinum Member
May 5, 2000
Which OS are you using. Does it autodetect the card in basic mode but you have to later put in the 3d/glide parts of it?

That probably didn't make any sense, but here's what I do anyway.

I have a V3 3000 and velocity 100. I recently moved and I have no friggin clue where my velocity 100 drivers are, so I wondered if my V3 CD would work at installing it. No problem at all. now I can run V3 1.05 drivers on it with no problems. Throw in a registry tweak to get the second TMU to work and it's a pretty darn good card.

The V3 drivers MIGHT actually be installed, just check under device manager. I too can't get anything to show up when I click setup, but it does actually copy the drivers to the right place.

If worst comes down to it, let me know if you need a copy of the V3 install disc and I'll send it to you so you can install your card correctly.