• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Underperforming Card

sr7108

Junior Member
Oct 20, 2012
5
0
0
I just completed a new built. Started playing Borderlands 2 on High everything. FPS was only about 10-15 sometimes lower. Tried L4D and the FPS was only 15-20 on High everything as well. Ran 3DMark 11 and only got a combined score of 3200, predicted was 5500. Have updated my drivers and installed the GPU drivers a couple times.


Specs:
CPU: i5-3570k OC @ 4.2 GHz
RAM: 8 GB Patriot @ 1600
GPU: MSI R7870 Hawk
PSU: OCZ Fatal1ty 750 W
MoBo: Asus P8Z77-V Pro

I have reinstalled the drivers multiple times, doesnt seem to help or hinder. Also, i have disable AA and tessellation in CCC and disabled onboard video, only bumped fps about 1-2 in borderlands 2. Anyone have any ideas as to what I could do to fix this?
Thanks
 

MrK6

Diamond Member
Aug 9, 2004
4,458
3
81
For Borderlands make sure you have PhysX set to Low. PhysX is poorly developed in general, and the parallel nature of hardware physics really does a number if only the CPU processes it (CPU's are better serial processors). As far as your 3DMark11 score, check your control panel settings and make sure they are set to default and then run it again (extra AA will lower your score, for example). Also make sure you installed your chipset drivers (Intel INF) before your graphics driver, as that sometimes can degrade GPU performance.
 

tweakboy

Diamond Member
Jan 3, 2010
9,517
2
81
www.hammiestudios.com
Something is wrong. You should be getting 60fps constant avg.

When did this low fps problem start ? Or have you had it ever since you installed OS ?

Also did you have a nVidia card before you got the 78xx ATI card ? If you did then you need a clean format.

Going from ATI to nVidia or going from nVidia to ATI ,,, Can cause problems,, BSODs and slow slow FPS.
If you indeed had a geforce in this same OS you need a clean format and install ATI 12.9 and your off! let us know..
 

BallaTheFeared

Diamond Member
Nov 15, 2010
8,115
0
71
PhysX is simply amazing in BL2, unfortunately you'll need a dedicated Nvidia card for medium or higher with your CPU.


That said there is clearly something else at play other than PhysX, can we see your 3DMark11 results?
 

BallaTheFeared

Diamond Member
Nov 15, 2010
8,115
0
71
Interesting, Physics looks fine, however the gpu score is really low but still fast enough to handle the games you play - then in combined it takes major dive.

What driver version are you using?
 

BallaTheFeared

Diamond Member
Nov 15, 2010
8,115
0
71
That is really weird, unfortunately I've never seen anything like this before. I wish I could help but I have no idea what to tell you.

The cpu seems to be fine from the results, the gpu seems to running much slower than it should be, once you hit combined your results just utterly tank.

Have you tried other gpu drivers?
 

MisterMac

Senior member
Sep 16, 2011
777
0
0
Do a driver sweep and reinstall with AMD based drivers.


Just to be safe - are you ocing?
or only with the stock OC from the Hawk?


It could sound like throttling of some kind.
 

sr7108

Junior Member
Oct 20, 2012
5
0
0
I wipped all my amd drivers using atimans removal utility and reinstalled the drivers from the ati site. New 3dm11 scores: http://www.3dmark.com/healthcheck/3dm11/4707743. Significant change however still now where it should be.

I am not OCing anything at the moment.

I played BL 2 and fraps reported a constant FPS of about 60 with dips to about 45 during intense battles. This is great however most people with similar cards are reporting about 75 fps on stock cards.

Anything else you guys can think of to boost the performance?

Thanks for all the help so far guys
 

MrK6

Diamond Member
Aug 9, 2004
4,458
3
81
Load up MSI Afterburner and see how your card behaves using the real-time monitor. Check that it's clocking up to the proper clocks, that it's being fully used, that the temps are OK and it's not throttling, etc.
 

zaydq

Senior member
Jul 8, 2012
782
0
0
I wipped all my amd drivers using atimans removal utility and reinstalled the drivers from the ati site. New 3dm11 scores: http://www.3dmark.com/healthcheck/3dm11/4707743. Significant change however still now where it should be.

I am not OCing anything at the moment.

I played BL 2 and fraps reported a constant FPS of about 60 with dips to about 45 during intense battles. This is great however most people with similar cards are reporting about 75 fps on stock cards.

Anything else you guys can think of to boost the performance?

Thanks for all the help so far guys
People are reporting 75fps? Their vsync is off. Turn your vsync off if you want to compare to their 75fps. Did you plug in the two 6+6 pin power connectors on your card? Is the card fully seated into the PCI-Ex16 slot? Are you, by chance, not in a PCI-Ex16 slot?

I have a feeling you may have overlooked something, especially curious on whether you have the card in a PCI-Ex16 slot or a PCI-Ex4.
 

sr7108

Junior Member
Oct 20, 2012
5
0
0
Vsync was off, all other graphics options were set to high or unlimited and the resolution was set to 1680x1050. The people who got the 75fps used a resolution of 1920x1050. All power connections were seated correctly, checked using HWMonitor to check the voltages and the card is in aPCI-E3 x16 according to GPU-Z.
 

zaydq

Senior member
Jul 8, 2012
782
0
0
Vsync was off, all other graphics options were set to high or unlimited and the resolution was set to 1680x1050. The people who got the 75fps used a resolution of 1920x1050. All power connections were seated correctly, checked using HWMonitor to check the voltages and the card is in aPCI-E3 x16 according to GPU-Z.
Hmm okay. I didn't intend to make you out as an idiot or anything but sometimes the silliest things can be the problem. in your CCC what is your Anti-Aliasing Mode? Is it set to Multisample AA, Adaptive Multi-Sample AA, or Super Sample AA? I know the Adaptive one is quite problematic.
 

CarpeDiem99

Senior member
Sep 22, 2003
518
0
71
Check your gpu usage and see if it is at 100% when you are gaming. You can do this with GPU-Z or MSI Afterburner.
 

ASK THE COMMUNITY