The stupidest thing I've ever done.

Discussion in 'The Garage' started by SSSnail, Nov 4, 2012.

  1. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    So, I was replacing my crankcase vent valve. While disconnecting the electrical connectors, I thought that they're all different and paid no mind to which goes where.

    After all is done, I put everything back and tried to start the car. Well, the fuel pump made cluck cluck cluck cluck noise, and of course, didn't start.

    Dissecting everything, there were two plugs switched. I think something is fried.

    Anyways, moral of the story is, label everything. It was such a stupid thing that will cost me dearly.
     
  2. Vic Vega

    Vic Vega Diamond Member

    Joined:
    Sep 24, 2010
    Messages:
    4,537
    Likes Received:
    0
    Where is your PCV that you had to dissect electrical connectors? Most engines it's just sitting on the valve/cam cover...
     
  3. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    This one sits in the heart of the engine, underneath the intake manifold, had to take out the DISA and throttle body just to see it, and still a bitch to get it out.

    There's an electrical panel with a bunch of plugs on it that I had to get it out
    of the way. So, I went happy with the unplugging...

    Someone's pic for illustration, this view is after the intake assy., MAF, and the electrical box out of the way. It's the thing left of the throttle, D.
    [​IMG]
     
  4. wirednuts

    wirednuts Diamond Member

    Joined:
    Jan 26, 2007
    Messages:
    7,121
    Likes Received:
    1
    i do this kind of stuff all the time. i seem to learn how to label then i stop doing it after awhile, and i end up ruining something. then i go back to labeling for a bit, then i stop. dont feel bad.
     
  5. exdeath

    exdeath Lifer

    Joined:
    Jan 29, 2004
    Messages:
    13,643
    Likes Received:
    0
    I've always found it impossible to do something like this.

    If the connectors aren't uniquely keyed, then the routing and length of the harness pigtails pretty much make sure everything goes back to the right place without even thinking about it.

    The whole reason the harness and connectors are designed like this is to be idiot proof during the assembly process by wage workers on the assembly line. Even if the connectors weren't keyed, you can generally start unwinding the harness, and when you arrive at a connector, there is going to be one convenient place on the engine where it can go.

    Same goes for just about anything. Wage workers in a factory with zero technical background can assemble a multi million dollar cruise missile while drunk and blind folded, if the designers did their jobs right.
     
    #5 exdeath, Nov 4, 2012
    Last edited: Nov 4, 2012
  6. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    Yeah, that's what I thought too, it just happen that there were TWO connectors keyed exactly the same, and coincidentally and unfortunately have the same wire length. Maybe not exactly, but one would reach the others, hence the * up.
     
  7. exdeath

    exdeath Lifer

    Joined:
    Jan 29, 2004
    Messages:
    13,643
    Likes Received:
    0
    As I always say in these types of situations, time to buy a lottery ticket!
     
  8. wirednuts

    wirednuts Diamond Member

    Joined:
    Jan 26, 2007
    Messages:
    7,121
    Likes Received:
    1
    yup! turn magic circuit smoke into lemonade!
     
  9. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    I'm gonna need a car to do that... :hmm:

    Gonna put it on a flatbed to the dealer on Monday.
     
  10. phucheneh

    phucheneh Diamond Member

    Joined:
    Jun 30, 2012
    Messages:
    7,313
    Likes Received:
    0
    ...so what did you do? Perhaps we can help you put the magic smoke back into whatever electronic part you fried. ;)

    You sure the connectors weren't broken? I've actually seen people break external keys off of connectors because it was keeping it from fitting (into the wrong hole). Your mistake might have been the fault of a previous rocket scientist.

    Was it those two connectors you can see in your pic? Looks like a purge solenoid and an oil pressure sender. I don't see what you could have damaged. Worse case, you put power to the wrong side of the oil pressure sending unit (or low pressure switch...whatever it is).
     
    #10 phucheneh, Nov 4, 2012
    Last edited: Nov 4, 2012
  11. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    I don't remember what all the plugs were, but I think there were about 7 of them. Off top of my head: MAF sensor, DISA valve, throttle, idle control, oil sending, something that came off the alternator, something that plugged into the board, something that came off the purge valve...

    So worse case scenario, what's that going to cost me? Well, of the two that crossed, I think they were whatever that came off the alternator and the purge valve. But, what the hell do those have to do with the fuel pump underneath the rear passenger seat?
     
    #11 SSSnail, Nov 4, 2012
    Last edited: Nov 4, 2012
  12. phucheneh

    phucheneh Diamond Member

    Joined:
    Jun 30, 2012
    Messages:
    7,313
    Likes Received:
    0
    Well, purge valve connector has two pins. One is switched B+. The other is grounded by the ECM (but not at initial startup).

    A standard, internally regulated alternator with a two pin alternator connector (a 'three wire' setup, adding in the post for the charging output) should have a voltage supply wire and a voltage sensing wire.

    So alternator connection to purge solenoid shouldn't hurt anything. Purge solenoid to alternator...I'm not certain. It's possible you backfed voltage through the driver for the purge solenoid, maybe? I don't see this doing anything to the computer other than frying that specific driver (so the ECM would be 'bad' but your only symptom would be a malfunctioning evap system).

    You sure those are the two you swapped? Those two having the same connectors and being anywhere close to each other is pretty unlikely...
     
  13. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    Well, one plug has one orange wire, and the other goes to the purge valve. Now thinking about it, it was a plug that goes to the oil sender and the purge valve.

    Meh, the car is going to the dealer tomorrow. I don't know why the fuel pump was fried though, it made weird noises, and engine turned, but didn't start. Check engine light flashed while trying to crank. I assumed the fuel pump was bad. But, I didn't do anything to it, so I guess something else is fried that effected the fuel pump.
     
    #13 SSSnail, Nov 5, 2012
    Last edited: Nov 5, 2012
  14. phucheneh

    phucheneh Diamond Member

    Joined:
    Jun 30, 2012
    Messages:
    7,313
    Likes Received:
    0
    The only thing that comes to mind for me is that whatever you did shorted power to ground and you blew an engine-related fuse. Or you smoked a printed circuit or some such inside an ECU before a fuse could blow.

    What is the car doing now when you try and start it? What works and what doesn't?

    It would really help to know what connectors you switched, but at the same time you should still be able to use a diagnostic process to figure out what the problem is. Even if you were approaching the vehicle with no information about what had happened to it, you should eventually be able to pinpoint the problem with a multimeter, some test leads, and some documentation (fuses and relays (owner's manual), engine wiring diagram).

    edit: An important thing to note is that it doesn't matter what the hell you did to the purge solenoid. It's just a coil of wire; basically a resistor...it has no voltage or ground inside it and it can't short anything together. And if you somehow killed it, it won't keep the engine from starting. So the question is what did you hook the purge valve's connector to...either you applied power to an ECM ground circuit, or you shorted the purge valve's power supply to ground.
     
    #14 phucheneh, Nov 5, 2012
    Last edited: Nov 5, 2012
  15. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    Well, when I try to power on, I can hear the fuel pump making very loud click click click click noise, then it stops. If I keep cranking, then the start cranks, but the engine doesn't turn over. I supposed whatever it is that I switched fried the fuel pump, or something related, and now there's no fuel to the engine so it won't start.

    I double checked to make sure everything is tight and snug, vacuum, etc... are all good. I just have basic tools, no multimeter, etc...
     
  16. LTC8K6

    LTC8K6 Lifer

    Joined:
    Mar 10, 2004
    Messages:
    23,731
    Likes Received:
    15
    Photos before dis-assembly are good to have as well.
     
  17. phucheneh

    phucheneh Diamond Member

    Joined:
    Jun 30, 2012
    Messages:
    7,313
    Likes Received:
    0
    What is 'cranks but doesn't turn over?' Are you saying the engine cranks ('turns over' would be a synonym) normally but doesn't start? I.e. as if there is either no spark and/or no fuel?

    Are you sure it's the fuel pump making the noise?

    Is there a shrader valve (tire valve, basically; will have a plastic threaded cap on it) on the fuel rail? If so, poke it (watch your eyes) and see if pressurized fuel squirts out.

    I just don't see what you could've done that would cause an electric pump to make a clicking noise. Find the fuel pump relay under the hood, pull it, and see if the noise stops.
     
  18. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    Yeah, if I turn the key to 2nd position, I can hear the fuel pump very loudly. If I turn the key to the crank, the engine turns, but doesn't start. The noise from the fuel pump is only heard during the initial pump session, then it stops.

    Yes, I'm sure it's the fuel pump that's making the noise, because it sits right below the rear passenger seat in my car.

    Here's a picture of my engine bay, completes with color coded arrows of the plugs. I also remember that I didn't plug in a plug at the bottom of the conduit box. Color arrows are as follow:

    RED : the brown plug that connects to the oil filter housing, I guess this is the oil sender unit that you spoke of. I plugged that into the purge valve.

    GREEN: the purge valve and its plug, which I initially plugged into the oil thingy.

    YELLOW: the plug at the bottom of the conduit box that I forgot to plug in.
    [​IMG]
     
    #18 SSSnail, Nov 5, 2012
    Last edited: Nov 5, 2012
  19. phucheneh

    phucheneh Diamond Member

    Joined:
    Jun 30, 2012
    Messages:
    7,313
    Likes Received:
    0
    Oh, random other thought- it is possible you 'partially' blew a fuse. I usually see it when someone attempts to hook a battery up backwards...the consumable part of the fuse starts to burn up but doesn't quite get there- and the fuse turns into a load on the circuit. So you see battery voltage on side, maybe a few volts on the other. This might allow the fuel pump to try to work (but fail).

    If you pull the relay and determine that it is the fuel pump making the noise (nothing else gets fed by that relay), find the associated fuse and check it. If it's good, check the voltage on it while the pump is running/trying to run and see if it drops noticeably.

    If not, I'd then go to the pump and determine if you have an actual issue with wiring or a bad pump motor. Would have to be one of the two.

    And I'm gonna just keep assuming you have a multimeter. 'cause you should, unless you stick to working on cars with a carb and distributor. With points. And a hand-cranked starter. Seriously- a meter is the single most useful diagnostic tool you can own.

    You don't have to buy a Fluke. It just needs to vaguely work.
    http://www.autozone.com/autozone/ac...multimeter/_/N-26lr?itemIdentifier=64472_0_0_

    Hell, for voltage checks, a Harbor Freight meter will work. For some amount of time, at least. Five dollars. You can crumple it up and throw it away when you're done.
    http://www.harborfreight.com/7-function-multimeter-98025.html

    Also test leads/jumper wires. Just don't short to ground and melt the insulation, then lacerate your hand with a burning wire. It kinda hurts and stuff.
    http://www.harborfreight.com/36-inch-low-voltage-test-leads-66712.html
     
  20. phucheneh

    phucheneh Diamond Member

    Joined:
    Jun 30, 2012
    Messages:
    7,313
    Likes Received:
    0
    But none of the stuff in that last picture has anything to do with the fuel pump, except perhaps sharing a common main fuse.

    Also plug in your TPS.

    Also is a conduit box something like a fusebox? 'cause plugging in the fusebox correctly would be crucial. Again, obtain multimeter + check fuses (for proper voltage; not visually) might save the day here...
     
    #20 phucheneh, Nov 5, 2012
    Last edited: Nov 5, 2012
  21. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    Thanks phucheneh.

    The conduit box has all the wiring coming out of it for throttle body, MAF, DISA, the purge valve and some other thing, fuse box is somewhere else.

    I'm just going to give this to the dealer...
     
  22. Kroze

    Kroze Diamond Member

    Joined:
    Apr 9, 2001
    Messages:
    4,052
    Likes Received:
    0
    This is why I love honda for the pure simplicity of maintenance.
     
  23. jagec

    jagec Lifer

    Joined:
    Apr 30, 2004
    Messages:
    24,442
    Likes Received:
    0
    One time when I was young and stupid I managed to mislabel my plug wires when I was changing out the head (worn valve guides, changed it out for a junkyard head that had fewer miles on it). My 4-cylinder engine became a 2-cylinder engine just like that. It still ran, just with VERY little power. It took me an embarrassingly long time to figure it out.
     
  24. phucheneh

    phucheneh Diamond Member

    Joined:
    Jun 30, 2012
    Messages:
    7,313
    Likes Received:
    0
    If I seem like I'm being overly technical or a bit of a douche, I apologize, I'm just trying to save you the trip to the stealership. You really can figure it out with a little help; nothing magical has happened.
     
  25. SSSnail

    SSSnail Lifer

    Joined:
    Nov 29, 2006
    Messages:
    17,322
    Likes Received:
    48
    Totally appreciated. I figure if it's the fuel pump, they can replace it anyways. I have a set amount of time to spend on this project, arbitrarily set by me. At this point, I'd rather not mess with it any more.

    It may be as simple as relay, fuse, but I don't have the tool right now to find out. Besides, I'm already at the dealer...

    I don't know, this might be an opportunity for me to get a new car. :awe: