Subwoofer issue

Nikana

Junior Member
Jan 23, 2013
4
0
0
#1
I have recently started using my PC as an HTPC, and with Steam Big Picture mode.

I also just got a new subwoofer to add to my set up, and it works great with every device except my PC.

The issue is that no matter what type of content I play, the subwoofer will just not respond. I am hooked to my receiver via HDMI, and I have my setup in the audio settings for 3.1.

I have tried all different types of audio including movie, music, and games.

My receiver always gets the signal as PCM. So I thought maybe the source just doesn't have a subwoofer channel. I fired up the Windows 8 Netflix app, and loaded up a movie with Dolby Digital, but still nothing. The HUD on the subwoofer says there is a sub connected so I know the receiver knows it there.

The AMD audio settings just kick me back to the windows sound panel, and I have tried to google this problem, but can't seem to find anyway to get the sub working.
 

kornphlake

Golden Member
Dec 30, 2003
1,554
0
76
#2
The problem is most likely a configuration issue on your PC, but just to confirm the receiver is setup correctly it would be a good starting point to try a different source, try tuning to an FM radio station you should get sound from the sub.
 

beyonddc

Senior member
May 17, 2001
911
0
76
#3
Under your 'Sound' settings, if you click on 'Configure' then you should see 'Speaker Setup'. In there you can set your 2.1 or 5.1 setup.

I am on a laptop and my soundcard only support stereo so it doesn't so all the options but on my HTPC, it has options for setting 2.1 or 5.1 setup.

 

nickbits

Diamond Member
Mar 10, 2008
4,125
0
71
#4
when you are playing dd, does the receiver indicate it receives a dd signal?

check the input settings and crossover settings on the receiver

try installing ac3filter
 

WT

Diamond Member
Sep 21, 2000
4,817
2
91
#5
Had the same problem with my 5.1 setup a few years back, and it was indeed a setting under the audio properties .. I can't remember if it was a checkbox for the full range speakers or similar setting under the enhancements tab.
 

Nikana

Junior Member
Jan 23, 2013
4
0
0
#6
Sorry for the delay. I thought I had responded but I guess I never hit reply.

I figured out the issue/ found a work around.

I reinstalled my drivers and made sure my sub was connected. I then enabled all the correct inputs on my machine, and then enabled the extra bass function on my receiver. Works like a charm now
 

ASK THE COMMUNITY

TRENDING THREADS