STRANGE!! Blank Screen On Pressing DEL During Startup

VinayakUpadhya

Junior Member
Dec 17, 2009
1
0
0
Hi,
I own an Asus A7N8X-E Deluxe mobo, 2 gb Kingston DDR1, XFX 6200 graphic card for 5 years now. Yesterday I tried accessing the bios but was unable to. Pressing DEL would lead to a blank screen with a blinking underscore on the top left corner. My computer boots up normally otherwise. No problems with the booting, just the access to the bios. I tried it several times but in vain. Interestingly I was able to access the bios the day before. Frustrated I was, I used asus update software to update my bios but during the process my computer hung and I lost the original bios. Now, with a lost bios my computer wont start.

I took the motherboard to the service center and learn't that the south-bridge had gone kaput and needed to be replaced. The technicians at the service center had reloaded the bios but found the problem to persist.

I do not understand. What did actually go wrong? Was it just a faulty bios or the south-bridge is actually capable of misbehaving in this manner?

Please help, cause I feel i'm being cheated by the service center. Would like to repeat- Computer did boot normally; only access to bios was not possible after pressing DEL; deleted bios due to system crash during its update.
 

theevilsharpie

Platinum Member
Nov 2, 2009
2,322
14
81
The southbridge controls access to most of your computer's I/O devices, so you'd certainly notice more than an inaccessible BIOS configuration screen if it was faulty.

You could try resetting the BIOS settings to the factory defaults by removing the CMOS battery, but you run the risk of not being able to make any necessary BIOS changes if you can't gain access to the system.