• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question *STABLE* NVMe - USB Adapter?

Page 21 - Seeking answers? Join the AnandTech community: where nearly half-a-million members share solutions and discuss the latest tech.
Jun 10, 2020
149
42
61
thermal throttling Is one possibility I will not cross out, if it happens 30-40 mins or more after initial connection especially if heatsink pads were not used/installed on the nvme memory for heat dissipation. So yes @Orbss also enable standby mode when idle after 1 (5 or 10 if you feel it is quick) minute to kick in. If you don't want to do that then I can't help I can only advise, it is one step to check until the next until you find the cause. Also you need, if you did not, install heatsink pads as well,

I have.moved my JMS583 PCB to JMS580 enclosure (PCB have same dimensions) which has better heatsink as a precaution and to avoid thermal throttling and premature nvme or jms583 Chip or pcb parts failure.
 
Last edited:

Orbss

Junior Member
Dec 5, 2020
7
0
6
thermal throttling Is one possibility I will not cross out, if it happens 30-40 mins or more after initial connection especially if heatsink pads were not used/installed on the nvme memory for heat dissipation. So yes @Orbss also enable standby mode when idle after 1 (5 or 10 if you feel it is quick) minute to kick in. If you don't want to do that then I can't help I can only advise, it is one step to check until the next until you find the cause. Also you need, if you did not, install heatsink pads as well,

I have.moved my JMS583 PCB to JMS580 enclosure (PCB have same dimensions) which has better heatsink as a precaution and to avoid thermal throttling and premature nvme or jms583 Chip or pcb parts failure.
I use my RTL9210B with this heatsink and double sided pads so I don't think heat dissipation is an issue here.
 

Andalu

Member
Jun 25, 2020
93
65
51
I just reuploaded @Andalu file from his link so that you have an additional file link for a longer time. I don't accept any credits :).
A bit off topic, just to clarify that I don't have a dropapk subscription, so here too there are no credits.
I chose this service simply because it doesn't require a registration to upload files and even the download is free and requires only to enter a simple code. But mostly because the download can be completed even without allowing the included scripts (the one for geolocation is not present anyway), using a simple browser add-on to block them.
I don't like services that require mandatory authorization of some or even of all scripts to allow the download, especially those that would possibly have a geolocation.
 
Last edited:

Adam Strange

Junior Member
Dec 11, 2020
7
1
11
Hello everyone. I have a Sabrent enclosure with jms583 chip and its work fantastic on my macbook pro 2019 but on my new mac mini with apple silicon M1 processor I can see maximum 560-630 mb/s
I already contacted apple support they said I have to contact a company who produced the enclosure and ask them about a fresh driver or firmware. I'm googled and found this thread and already tried 2.0.9 firmware but it's also useless for me I still can reach only 630Mb max. any ideas what I can try to solve it?
As I said before on my macbook pro I can see a real possible speed 960-980Mb
 
Jun 10, 2020
149
42
61
Three other possibilities
1. You need to format m.2 nvme and retest speed. This happened to me as well.
2. Update your pc bios.
3. Could be m.2 nvme firmware too. Try finding a free nvme slot on a desktop pc and update m.2 nvme firmware.

And a forth one :) update your chipset drivers (ahci) if any, and check bios if ahci is selected.

I doubt it is a problem with jms583 firmware.
 

Adam Strange

Junior Member
Dec 11, 2020
7
1
11
Three other possibilities
1. You need to format m.2 nvme and retest speed. This happened to me as well.
2. Update your pc bios.
3. Could be m.2 nvme firmware too. Try finding a free nvme slot on a desktop pc and update m.2 nvme firmware.

And a forth one :) update your chipset drivers (ahci).
I already format it in different file systems - same speed
Mac mini bios can't be updated.
Don't have any opportunity were to update m.2 nvme firmware, can i update it using this nvme enclosure?
We talking about apple computers there are no such things as drivers. Only system updates
 
Jun 10, 2020
149
42
61
No you cant update nvme firmware using the enclosure.

Are you sure mac mini is usb 3.1 gen 2 (10Gbps) compatible?? Try using all other usb ports one by one and retest.

Also test with rtl9210 enclosure to remove uncertainty.

Do you have zero standby timer as recommended by jeyi i9 for IOS devices??
 
Last edited:

Adam Strange

Junior Member
Dec 11, 2020
7
1
11
No you cant update nvme firmware using the enclosure.

Are you sure mac mini is usb 3.1 gen 2 (10Gbps) compatible?? Try using all other usb ports one by one and retest.
Definitely sure. RTL9210 gives me 890Mb enclosure from Orico but I don't really like the quality of the case. So I decided to buy a Sabrent it's more solid. But I didn't know what can be some kind of issue like this. The new mac mini has two thunderbolt/USB 4 ports that support usb3.1 gen 2 (10gbps)
 

Adam Strange

Junior Member
Dec 11, 2020
7
1
11
Do you have zero standby timer as recommended by jeyi i9 for IOS devices??

this part is really not understood. Where can I check it?
 
Jun 10, 2020
149
42
61
As my last recommendation go to advance power option settings and select
Pci express off
Usb setting suspend off

Then go to device manager and select usb controllers and usb devices and disable power management.
 

Adam Strange

Junior Member
Dec 11, 2020
7
1
11
As my last recommendation go to advance power option settings and select
Pci express off
Usb setting suspend off

Then go to device manager and select usb controllers and usb devices and disable power management.
where I can find these power options?
Mac os don't have this kind of settings ((
 

andyhi

Junior Member
Nov 23, 2020
6
3
41
That’s all what Mac mini have about power settings 😂😂😂
See this thread about people asking questions related to lower than expected M1 USB-C speeds... Might be firmware/driver related on M1 USB-C ports or could be misunderstanding / misrepresentation of the M1's USB-C capabilities. gen 1 / gen 2 / (1 ) 5gpbs lane vs (2) 5gpbs lanes, TB4, etc.

 

Josh68

Junior Member
Dec 20, 2020
5
0
6
jms583 firmware available for M2x (firmware 2.09).
Hello. I have a MyDigitalSSD M2X with a 1TB HP EX920 NVME M.2 drive. This setup has failed suddenly after 2 years of unproblematic use. First I thought the drive was going (I had a S.M.A.R.T. failure and bad superblock report), but then I wondered if the controller could be the problem. In Windows, the drive shows as uninitialized, and trying to set to GPT or MBR results in "The Request Failed Due to Fatal Device Hardware"

I tested the M2X with another NVME M.2 SSD, and since I couldn't get to that drive from the M2X, either, I started thinking the problem could be with the enclosure. I don't have a device that can take an NVME M.2 drive natively, which would be the best way to figure this out, obviously.

I flashed the manufacturer's official v209 firmware to see if it would help, but still couldn't get to my drive. Flashing seemed to go fine, and now I cannot reflash or downgrade, since that's how their firmware package works.

I then tried flashing v209 with the tool linked elsewhere here, using a provided config (JMMassProd_v1_16_15_12 with the updated JMMassProd.ini). This config seems to change a bunch of strings and a setting or 2. Again the flash worked fine, but still my drive isn't recognized.

My question is whether I can now somehow extract a config from the "official" firmware to reflash the enclosure and set everything back to what it was. I've opened the MyDigitalSSD executable, but can't seem to find a config. Anyone have any ideas on how to do this, or if it's possible?

Also, has anyone ever solved issues with a JMicron enclosure if you suddenly cannot access or initialize the drive within? Apologies if this is addressed somewhere in this thread and I missed it.

Thanks
 

Mekks

Junior Member
Dec 21, 2020
3
0
11
I have a JEYI i9 GTR on the way, will be running this to a Rasberry Pi/NAS style setup. I will be running a spare inland 1tb m.2

Anyone know if the usb cables that come with the unit are good or should I look into something else? and if so, what you would advise?
 

ASK THE COMMUNITY

TRENDING THREADS