ssh problem: no public key

Discussion in '*nix Software' started by xSauronx, Dec 9, 2007.

  1. xSauronx

    xSauronx Lifer

    Joined:
    Jul 14, 2000
    Messages:
    19,591
    Likes Received:
    0
    :(

    Setup:

    tower : vmware host : Debian Etch - actium
    tower : vmware guest : CentOS 5 - vienna
    Laptop : Ubuntu 7.10 - pergamum

    i set up thevmware host today and wanted to have ssh running between all of the systems, so i go around with the sshd set to allow password use so i can copy the keys as i need them

    then i set all the sshd servers to allow passwordless public key authentication

    i can ssh FROM actium TO pergamum
    FROM vienna TO pergamum
    FROM pergamum TO actium
    FROM actium TO vienna

    i cant shh from actium or pergamum into vienna, as i get a "Permission Denied (no publickey)" error :/

    but i cant figure out *why*. i did the exact same thing i did on the other two machines.

    xsauronx@$client: scp ~/.ssh/id_rsa.pub $remotehost:~/.ssh/id_rsa.pub.$client
    then from the remotehost
    xsauronx@$remotehost: cat id_rsa.pub.$client >> authorized_keys

    again, on the laptop and the vmware host machine, it works flawlessly

    but i cant ssh into the CentOS guest with the key. If i enable cleartext passwords it works, but of course, thats not what I want

    what can i do? am i overlooking something?

    heres the /etc/ssh/sshd_config from vienna:

     
  2. Loading...

    Similar Threads - problem public Forum Date
    New install of UbuntuMate and having problems sharing a folder *nix Software Sep 11, 2016
    Vsync problems with multiple distros with Intel 4600 IGP and i915 driver *nix Software Dec 17, 2015
    Upgraded to Ubuntu 14.04 problem *nix Software Mar 11, 2015
    Weird Ubuntu + printer problem *nix Software Mar 7, 2015
    what can I do with a public shell account? *nix Software Feb 18, 2015

  3. Skeeedunt

    Skeeedunt Platinum Member

    Joined:
    Oct 7, 2005
    Messages:
    2,777
    Likes Received:
    3
  4. Nothinman

    Nothinman Elite Member

    Joined:
    Sep 14, 2001
    Messages:
    30,672
    Likes Received:
    0
    Permissions are usually the problem, up the verbosity of ssh (or run the server in debug mode) and it'll probably tell you exactly what's wrong.
     
  5. xSauronx

    xSauronx Lifer

    Joined:
    Jul 14, 2000
    Messages:
    19,591
    Likes Received:
    0
    permissions was it, d'oh!

    thanks guys :)