Question Server not booting up with Intel S2600CP4 server board, No Motherboard Error beeps either.

IT Reseacher

Junior Member
Feb 13, 2021
We have a Intel S2600CP4 Server board fitted inside a brand new Chenbro server Chassis. One CPU slot on the Motherboard is populated with Intel E5-2695V2. Other slot is left empty, but both CPU power pins are attached on the Motherboard. The Heat sink on the CPU has thermal paste properly applied and is fitted in the right direction. The chassis houses a 960+ 960W Redundant Powers Supply Unit. No hard disks are connected.
Now when the server is turned on the, heat sink fans on the CPU starts spinning for a few seconds and then stops and this pattern repeats. Also the Motherboard does not give out any error beeps either.
No Error indications on the Motherboard LEDS also. Plus we also don’t see any Boot screens.
- CPU : E5-26952 V2
- Chassis : Chenbro RM-41824-960R
- PSU : 960+960W Redundant Power Supply

What we have tried:
- Tried swapping the PSU units on chassis.
- Tried Resetting the CMOS by removing the battery
- Disconnected everything and connected only CPU and Motherboard power outside of the chassis.
- Tried with and without RAM.
- No External Cards attached.