RAM count problems on a Dell Dimension XPS Gen 4

Discussion in 'Computer Help' started by DaManDOH, Feb 6, 2013.

  1. DaManDOH

    DaManDOH Junior Member

    Joined:
    Feb 6, 2013
    Messages:
    1
    Likes Received:
    0
    'Twas a simple process. I have some out-of-warranty Dimension XPS Gen 4 workstations in my lab that we're phasing out. However, no one wanted to toss the hardware altogether, so we took the peripherals and RAM from half of them and tossed them into the other half. Ideally, this should have resulted in half the number of Dells (3) with twice the amount of RAM (4.0 GB). As I said: simple.

    While the BIOSes of the remaining machines do indeed report four 1.0 GB DIMMs installed on each board, no OS nor utility can see all 4 gigs. They all report only 3.0 GB available. I've tried 64b Linux distros (Ubuntu 10.04 LTS and 12.04 LTS plus Debian 6.0.6), 64b Win7 Enterprise, as well as 32b and 64b memory diagnostic software. None of them see all 4 GBs of RAM which I've installed.

    Utilizing Memtest+ v4.20, I've tested each DIMM by itself and with every pairwise combination in each DIMM slot. I even tested three of them together at once. In every case, multiple passes came out clean. The DIMMs and the motherboard seats are good. I even upgraded the BIOS of my testbed machine to A07: the most recent version released by Dell (in Summer of '05). No difference. This is happening with the other two jalopy Dells as well, so clearly this isn't a software issue; it's a hardware configuration issue. How do I proceed?

    Thank you for your time and consideration.


    P.S. This post was also submitted to Dell's support forum and can be found here:
    http://en.community.dell.com/support-forums/desktop/f/3514/p/19490268/20294153.aspx#20294153
     
    #1 DaManDOH, Feb 6, 2013
    Last edited: Feb 6, 2013
  2. Loading...

    Similar Threads - count problems Dell Forum Date
    Hardware problems. Need some pointers. Computer Help May 17, 2017
    Memory Test on Boot displays no count Computer Help Nov 14, 2009
    won't count memory Computer Help Aug 29, 2007
    80K and counting Computer Help Mar 8, 2005
    Clock counting too slowly? Computer Help Feb 15, 2005

  3. homebrew2ny

    homebrew2ny Senior member

    Joined:
    Jan 3, 2013
    Messages:
    465
    Likes Received:
    5
    Unless I am mistaken, a 32bit OS can only see/address ~3gb of ram regardless of what the bios reports..

    EDIT: never mind, I see you had tried this on a 64bit OS....

    Good luck with the fix!
     
  4. Smoove910

    Smoove910 Golden Member

    Joined:
    Aug 2, 2006
    Messages:
    1,188
    Likes Received:
    0
    so if you have 4gb total, how much do you have allocated to your onboard video? Sounds like you have 3gb system and 1gb video.
     
  5. denis280

    denis280 Diamond Member

    Joined:
    Jan 16, 2011
    Messages:
    3,409
    Likes Received:
    5
    Certain components within the computer require address space in the 4-GB range. Any address space reserved for these components cannot be used by computer memory.
     
  6. Matt1970

    Matt1970 Lifer

    Joined:
    Mar 19, 2007
    Messages:
    12,323
    Likes Received:
    0
    Strange one. Does the Bios let you control how much memory the onboard video is using?