• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question AMD hd 4650 doesn't work on some of systems, WHY ?

furrkan209

Junior Member
Dec 15, 2020
2
0
6
* I am new on this forum but maybe you guys help me. That's really important for me and sorry If I have English mistakes hope you can understand them *

I am trying to make a new computer from secondhand (thrift) But I met a really crazy problem. I have AMD HD 4650 1GB DDR2 graphic card but it didn't work on GA-M61PME-S2 (rev 2.1) motherboard. But it used to work normally on this board. NOTHING happened and when I try to open gigabyte board system the screen was just black and I just could get a display on onboard graphic. Then I tried to open this system with 750ti everything was just fine. Okey then I thought mobo has problem and tried hd4650 on my current system (MSI 970A-G43) IT JUST WORKED FINE. And I also tested the cursed hd4650 on ASUS M4N78 mobo too It didn't work on this mobo too.
Methods I tried (btw always hd4650's fan works);
-Change lot of bios settings to work it properly but no result
-Vga bios update , but it looks like downgrade (Have a photo about it. Low quality because of whatsapp image)
-Changed even cpu, psu, hdd!
VGA BIOS UPDATE İNFO


QUİCK İNFO
HD4650 with GA-M61PME-S2 (rev 2.1) no screen (ddr2 mobo)
HD4650 with ASUS M4N78 (rev 1.01) no screen (ddr2 mobo)
HD4650 with MSI 970A-G43 works fine (ddr3 mobo)

750TI with GA-M61PME-S2 (rev 2.1 ) works fine (ddr2 mobo)
750TI with ASUS M4N78 (rev 1.01) works fine (ddr2 mobo)
750TI with MSI 970A-G43 works fine (ddr3 mobo)


my current system (that hd4650's worked fine system)
-Amd phenom ii x4 945
-MSI 970A-G43
-750Tİ Strix
-8gb ddr3 corsair ram dual channel
-500w psu

*Also I can use my system's second pcı express slot I can use 750ti and hd4650 together. And it is visible on device manager
*Request me if I am missing things .I will add all of them to sort out this cursed problem.
*Also Thank you even If you read this post
*And I have a question for you ;
https://www.techpowerup.com/vgabios/168127/168127 this one is same specs with my card but visual is literally same with https://www.techpowerup.com/vgabios/222321/222321 I tried both of them as bios update but 512mb one like bricked my card didn't even work on my current system and I flashed 1gb bios again it's worked same so why pictures different are they have wrong pictures ?
*The vga bios update image detail is stock bios to 1gb version bios update procces
*I thought like I explain it complicated so Added a quick info menu
 

Leeea

Golden Member
Apr 3, 2020
1,131
1,331
96
I read your thing, and I just want to check:

On the GA-M61PME-S2 are you running the latest BIOS? released 2010-01-12?

-------------

If I understand correct, you flashed the HD 4650 with a BIOS, it did not work, but then you flashed it with a different one and it did work-ish?

If true, is it possible the new BIOS you flashed on to the HD 4650 is not compatible with the GA-M61PME-S2, because it dropped legacy support?

If the above is true:
What brand / model is the HD 4650? -> You may want to consider finding the oldest BIOS you can for it, and flash it with that. The idea being to restore legacy BIOS support.
 

furrkan209

Junior Member
Dec 15, 2020
2
0
6
I read your thing, and I just want to check:

On the GA-M61PME-S2 are you running the latest BIOS? released 2010-01-12?

-------------

If I understand correct, you flashed the HD 4650 with a BIOS, it did not work, but then you flashed it with a different one and it did work-ish?

If true, is it possible the new BIOS you flashed on to the HD 4650 is not compatible with the GA-M61PME-S2, because it dropped legacy support?

If the above is true:
What brand / model is the HD 4650? -> You may want to consider finding the oldest BIOS you can for it, and flash it with that. The idea being to restore legacy BIOS support.
when I see the graphic card problem I just updated bios on GA-M61PME-S2 and ASUS M4N78 but it was still same, after that I decided to flash gpu bios for amd hd4650 but it didn't work for both of them. but while all this things happenning the MSI 970A-G43 worked fine with hd4650 . Actually thats all
 

Leeea

Golden Member
Apr 3, 2020
1,131
1,331
96
I am sorry, I am out of ideas but I will think on it a bit.

You have a hard one :(.
 
Thread starter Similar threads Forum Replies Date
X AMD 2
Whitestar127 AMD 1

ASK THE COMMUNITY