• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

PSA: Got AMD/nVidia HDMI Audio Issues? Don't forget to...

reallyscrued

Platinum Member
Jul 28, 2004
2,612
5
81
Install your sound card drivers.

Reinstalled Win7-64 with my recent acquisition of a 7850.

My video card is set up to output audio/video through HDMI to my receiver (RGB 4:4:4 and 5.1 PCM), it decodes the audio itself but passes video along through to my TV.

This card is a full 3 generations after previous 'legacy' 4890 and required new Catalyst drivers, 13.1, and these seem to have a peculiar quirk - if I turn off my television or receiver while the computer is still on, then come back later and turn my equipment on again, it will revert to stereo and not allow me to change to 5.1 in the Sound properties window. There will be no options for anything besides stereo.

A restart enables multichannel PCM again. Very annoying; I did not have to restart my computer every time I turned off my TV with my old Catalyst drivers.

I decided to go back to analog 5.1 for the time being, so I installed the Realtek 270 drivers that go along with the ALC899A codec on my board. Strangest thing - with the audio device installed, I never lose 5.1 Multichannel PCM from my 7850 now. From what I can tell, the Realtek drivers do absolutely nothing (all audio through them was working before) but now that it's installed, it seems to remind Windows that my computer is indeed capable of outputting 5.1, analog or not, from my Realtek or AMD device.

Anyway, live and learn. Install your dedicated sound card drivers all the time, even if you plan on using HDMI passthrough on the video card. That is all.
 

thestrangebrew1

Platinum Member
Dec 7, 2011
2,997
164
106
Are you using xbmc? According the their audio troubleshooting guide,
( http://forum.xbmc.org/showthread.php?tid=146911) you're supposed to remove your Realtek drivers because it conflicts with their audio engine (Frodo at least). I followed this guide and it works for the most part but I'm still having audio passthrough issues. If I just want to watch a show w/o my receiver on, I need to change my audio settings in xbmc as the wasabi AMD passthrough option yields no sound. I have to change the speaker config to stereo(?) instead of hdmi.
 

reallyscrued

Platinum Member
Jul 28, 2004
2,612
5
81
I've had issues with XBMC audio as well, but that's not what reverted to Stereo. It was the operating system - AMD driver itself.

Maybe I didn't make it clear, in the Sound properties dialog - Playback tab in Control Panel. If 5.1 or 7.1 isn't listed when you click your sound device (for me, it was AMD HD Audio), I was out of luck until I restarted my computer.

In AMD Catalyst Manager, turning my receiver and/or TV off and back on would result in the Audio tab graying every possible option for audio, so that was no help.

It hadn't even crossed my mind that installing my on-board soundcard drivers would keep this from happening, especially when 5.1 through AMD HD Audio worked fine upon start up, but after device disconnection, it would never reconnect; HDMI audio would appear "Not plugged in", even when I unplugged and plugged the cable back in.
 

reallyscrued

Platinum Member
Jul 28, 2004
2,612
5
81
Are you using xbmc? According the their audio troubleshooting guide,
( http://forum.xbmc.org/showthread.php?tid=146911) you're supposed to remove your Realtek drivers because it conflicts with their audio engine (Frodo at least). I followed this guide and it works for the most part but I'm still having audio passthrough issues. If I just want to watch a show w/o my receiver on, I need to change my audio settings in xbmc as the wasabi AMD passthrough option yields no sound. I have to change the speaker config to stereo(?) instead of hdmi.
brew, your issue lies elsewhere. Keep XBMC outputting its default 5.1 track.

If by that bolded statement I quoted, you mean you want the PC to send audio/video to your receiver, but you want your receiver to stay off and pass both streams along to your TV, you need to look at the appropriate settings at the Receiver level, not at your videocard/computer/program playing the media.

For my Denon, there is a setting in the Menu>Manual Setup>HDMI Setup>HDMI Control, setting that to "Last Source" allows me to turn my receiver off and allow audio/video to come through to my TV just fine. That's got nothing to do with XBMC or any other program.
 

thestrangebrew1

Platinum Member
Dec 7, 2011
2,997
164
106
Thanks I'll take a look at my receiver settings. I haven't had a whole lot of time to play around with the settings lately.
 

ASK THE COMMUNITY