• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Openwrt, how to edit dnsmasq.conf file on router..

TidusZ

Golden Member
Nov 13, 2007
1,765
2
81
My router log constantly shows:

Tue Aug 23 13:27:47 2016 daemon.info dnsmasq-dhcp[1256]: DHCPINFORM(br-lan) 192.168.1.248 50:e5:49:ef:54:f2
Tue Aug 23 13:27:47 2016 daemon.info dnsmasq-dhcp[1256]: DHCPACK(br-lan) 192.168.1.248 50:e5:49:ef:54:f2 TiduZIB-PC

over and over every minute

I've discovered through browsing google that the fix to this is to put:
dhcp-option=252,"\n"
inside the dnsmasq.conf file which is a package included in openwrt.

I have no idea how to access this file to put the above line into it to fix the problem. This is apparently a problem related to windows update.. If I run windows update it says looking for updates, forever.

I'm using a netgear wndr3700v2 with OpenWrt Chaos Calmer 15.05.1.

I have completely disabled the windows update service which didn't fix the issue.
 
Last edited:
Feb 25, 2011
16,572
1,333
126
Does your router have an SSH or Telnet connection option? (It should be disabled by default.)

Connect via that, and use vi to add that line to the /etc/dnsmasq.conf file, then service restart dnsmasq (or reboot the router.)

If you're not Linux-ey, this is a good time to start.
 

TidusZ

Golden Member
Nov 13, 2007
1,765
2
81
Thanks this fixed that issue. I used winscp to change the file.

Unfortunately it didn't end up fixing the lag I'm having though but I think I'm gonna just give up on that.
 

ASK THE COMMUNITY