Onn Android streaming box - flaky video

GunsMadeAmericaFree

Senior member
Jan 23, 2007
777
107
106
I've been messing around with the $20 Onn Android streaming box (from Walmart) for a couple of months. I'm really happy with adding an external USB flash drive and using VLC Media Player to play video files. Wasn't as happy with how I couldn't get the Accuradio app to load on it.

My biggest compaint, though, was intermittent video flashing, and the video going out. Yesterday I FINALLY figured out how to stop this. The box simply couldn't seem to handle the 4K video setting.

All of the flashing, and video going out for up to a second disappeared once I set it to 1080P. For whatever reason, it seems like the box just can't handle the 4k setting, but it seems to run fine on 1080.
 

VirtualLarry

No Lifer
Aug 25, 2001
54,048
8,259
126
My biggest compaint, though, was intermittent video flashing, and the video going out. Yesterday I FINALLY figured out how to stop this. The box simply couldn't seem to handle the 4K video setting.

All of the flashing, and video going out for up to a second disappeared once I set it to 1080P. For whatever reason, it seems like the box just can't handle the 4k setting, but it seems to run fine on 1080.
It's probably your hDMI cable.
 

sdifox

No Lifer
Sep 30, 2005
89,101
11,467
126
Probably doesn't have hardware hevc decoding so vlc is using software decode which is cpu bound.

Wait, the source video is 4k? Then I guess it could be the hdmi cable.
 
Last edited:
  • Like
Reactions: Trader05

GunsMadeAmericaFree

Senior member
Jan 23, 2007
777
107
106
Yep, turned out to be the HDMI cable that shipped with the unit! As soon as I replaced it, I put it back on 4k, and there were no issues at all. I never knew that video turning off for a second at a time could be a cable issue.
 

ASK THE COMMUNITY