NVIDIA® nForce IDE Performance Driver, ASPI and plextools?

Sled Dog

Senior member
Oct 10, 1999
Just put together a new machine, as follows..

ASUS a7n8x dlx
Athlon 2500+ Barton
40gig maxtor ide on primary channel
Plextor 24-10-40a on secondary ide channel
120gig Sata Maxtor on Sata channel 0
512mb of ocz dual channel ram
Adaptec 4.60 (1021) aspi layer, installed using Force aspi
Windoze 2k sp4
(Runs at 200x11, 2200mhz, solid.)

Plextools shows only the Sata interace 0, no Ide channels
whatsoever, wtf? The Plextor is recognized by windoze and
functions well for readin cds. Plextools system information
is as follows..

ASPI installation
wnaspi32.dll not used by Plextools pro
version 4.60 (1021)
Description ASPI for win32 (95/nt) DLL
Company Adaptec

Anyone know what part of this machine I need
to slap with my favorite hammer to get this idot
Plextools program to recognize my burner?
[pees] me off to spend all this money on new hardware
only to get this crap. I am NOT going back to my old
AMD K6II at 500mhz. Plextools help states that
it can run without aspi, but it is better to have it.
I've worked around some problems before, but this
hardware is a little newer than what I am used to.
Help please..

ore info..
Using Nforce2 Full 2.44 Swide driver
Ide channel setting Ultra DMA 2 - Ultra33.. autodetected.
Device type IDE ATA/ATAPI controllers
Manufacturer NVIDIA Corporation
Location PCI bus 0, device 9, function 0

PXinfo reports...
Plextor Info Utility V1.20
Copyright © 1999-2003 Plextor SA/NV
12 November 2003

Software Information

Operating system : Windows 2000 V5.00.2195 Service Pack 4
Windows ASPI (wnaspi32.dll) : Adaptec ASPI for Win32 (95/NT) DLL, V4.60 (1021) ( not used by PlexTools )
Roxio ASPI (cdral.dll) : n/a
Ahead ASPI (wnaspi32.dll) : n/a

Hardware Information

S-ATA Interface: 0 ID: - Maximum # Targets : -
Description :
Type :

Port Driver : si3112r.sys
Provider :
Description : Serial ATA RAID miniport driver (Silicon Image, Inc)
Location : D:\WINNT\system32\drivers\si3112r.sys
Version : 1, 0, 0, 281
Date :

Bus: 0

ID 0: Maxtor 6 Y120M0 VYAR5

Bus: 1

IDE Interface: 1 ID: - Maximum # Targets : -
Description :
Type :

Port Driver : nvatabus.sys
Provider :
Description : NVIDIA® nForce? IDE Performance Driver (NVIDIA Corporation)
Location : D:\WINNT\system32\drivers\nvatabus.sys
Version : 5.10.2600.0344 built by: WinDDK
Date :

USB Device Information:

# Host Controller \\.\HCD0 found.
Standard OpenHCD PCI to USB Host Controller

# Host Controller \\.\HCD1 found.
Standard OpenHCD PCI to USB Host Controller

Using ASPI Force I have removed the aspi, no joy.
Installed Steve Gibsons ASPIme, still no joy.
Is this so called performance Ide driver the problem?
Totally lost on this one.


Diamond Member
Apr 25, 2003
You could try the Adaptec ASPI layer found here. However, I don't know if it'll work or if it'll eat your installation of windows.

You actually included the copyright thingy AND capitalized nvidia? That's rare...

Sled Dog

Senior member
Oct 10, 1999
Ok, guess it can't hurt to try the newest. (or not). Don't care if it shags my instal. I live and breathe by the Ghost boot floppy.
Interestingly enough, using Ghost from within 2k will snarf 2k, bsod - Driver_IRQL_Not_Less_or_Equal...
3ea4595f-si3112r.sys. That being the Sata driver for 2k. I believe I had AdAware Adwatch set to start at boot as well.
Can't remember for sure, was up for 20 hours loading this new unit up. All I know is without Ghost floppy, I would have been
starting all over again. Anyway, was steering clear of the latest Adaptec aspi due to the bad reports I have read.
Duel boooting 98se and 2k, 98 was showing the ide within Plextools, before the last format/wipeout due to the fun with
these friggin nforce drivers. Haven't got around to puttin the drivers into 98 yet, just bare install since last wipe.
Gotta love these large drives for storing Ghost images. Going to try the new Adaptec now, let ya know...
Oh yeah, copyright and capitals.. copy paste. :)