NV drivers on the fritz... am I alone?

sykopath79

Senior member
Nov 2, 2000
458
0
0
I have been having endless problems with NVIDIA's drivers this week. I was using the 40.41s at the time. I will be using my computer, sometimes for a minute, sometimes for hours, and the screen will shut off, turn back on, shut off, turn back on... repeating this process over and over, all the while the interface frozen so I can't do anything but reach for the power switch. It did actually cough up a BSOD once or twice which blamed nv4_disp.dll.

So, first, running Windows XP at the time, I rebooted into VGA mode to completely nuke the drivers and install them fresh with no scraps left behind in the registry or anything. Same problem happened. I couldn't use my computer unless I was in Safe Mode or VGA Mode.

So I decided to format my hard drive and put a fresh install of Windows 2000 on instead (since XP likes to not let you have total control of your system). 100% fresh install of Windows 2000, I had not installed any other drivers at this point, and I install the NVIDIA 30.82s (most recent WHQL-approved set). Immediately I start having the same problems all over again.

After issuing forth a string of profanity worthy of a Quentin Tarantino flick, I nudged my GF3 around in its slot just for kicks (even though it was and is securely seated), and it seems to be behaving now, though still very flaky whenever it changes video settings (resolution, refresh, etc.) for whatever reason.

Has anyone had similar problems and discovered a fix?

Click the link in my sig if you need info on the rest of my rig...
 

AnAndAustin

Platinum Member
Apr 15, 2002
2,112
0
0
;) Well when trouble-shooting always set any o/c's back to defaults. Other than that I'd suggest it could be the Infinite Loop Bug, try these out:

Try to ensure any probs are not down to faulty hw, sw, corruption, viruses etc. Having the latest OFFICIAL drivers and BIOS' is always a good idea (be sure to check manu and chipset websites).

Check your BIOS settings, disabling 'PCI Master Read Cache' is VERY wise as it kills your L2 cache to give the PCI a 1% boost! Esp bad for Celerons and Durons. Enabling IRQ for VGA/AGP and setting AGP Aperture to 64MB can also help. Setting AGP1x or AGP2x (ie disabling AGP4x in BIOS) will hit perf, but not as badly as it sounds. The gfx card will continue to run at full speed it just limits the speed out of the AGP slot to 66mhz / 133mhz instead of 266mhz, not too bad at all, esp in the short term.

If you're running an older OS ensure you have DX8.1, good idea to reinstall it anyway. You may need to run DXDIAG, Diplay Tab, DISABLE Direct3D Accel & CLOSE the app. RERUN DXDIAG & ENABLE Direct3D Accel. A click of the TEST button will show if this solves your partic prob.

Leave the PCI slot next to the AGP empty, maybe try swapping your PCI devices through different slots, it's a good idea to have the PCI blanking plates at the back removed for ventilation anyway.

You could try disabling 'PnP OS' from the BIOS if you're using WinXP, apparently WinXP likes to do things itself. If you use any OS then perhaps setting PnP manually (reserving some resources) or resetting the PnP may also help. If you do change any BIOS settings, do make a note so they can be changed back if it doesn't help.

Try downloading NVMax. It has the infinite loop fix and other things for nvidia cards. http://www.nvmax.com/ http://www.charnleys.co.uk/NVmax4.exe http://www.softnews.ro/public/cat/12/1/12-1-8.shtml

Try different driver versions, with some cards 21.83, 23.11, 27.xx, 29.xx can help.
 

ASK THE COMMUNITY