NUC picture quality

phillyman36

Golden Member
Jun 28, 2004
1,604
48
91
Ok for you NUC/Kodi experts. What am I doing wrong? I have a NUC5CPYH. I have Windows 10 installed with Kodi installed. Can someone explain to me why my aging Dune smart media player has better picture quality than my NUC?






The tv is a Samsung HU8550. The darker one is from the NUC and the lighter one is from the Dune. I know its hard to judge pq from camera phones but you can tell Ant Man is too dark on the NUC.
 

nsafreak

Diamond Member
Oct 16, 2001
7,093
3
81
I know with my Samsung (different model) I had to calibrate each input separately. I'm guessing that your NUC is plugged into a different input than your Dune media player so you may just need to calibrate that particular input. If that's not the case, ie they're both running through an AVR which then sends the video to the TV, then you'll need to go into the Intel graphics control panel and make some adjustments to your gamma settings.
 

phillyman36

Golden Member
Jun 28, 2004
1,604
48
91
I know with my Samsung (different model) I had to calibrate each input separately. I'm guessing that your NUC is plugged into a different input than your Dune media player so you may just need to calibrate that particular input. If that's not the case, ie they're both running through an AVR which then sends the video to the TV, then you'll need to go into the Intel graphics control panel and make some adjustments to your gamma settings.
Both inputs are running the same settings. The NUC is running Kodi under Windows 10. Ill try to go and figure out what to adjust but this will be unfamiliar territory for me.

Ill try to find a thumb drive and see if Openelec gives me the same pq.
 

phillyman36

Golden Member
Jun 28, 2004
1,604
48
91
Ok the picture quality when running Openelec on the NUC is closer to my Dune vs running Kodi thru Windows 10.
 

LoveMachine

Senior member
May 8, 2012
491
3
81
In Kodi, go to the Settings tab->System->Video, make sure you have Expert Mode enabled (at the bottom of the menu in the Confluence skin), then find the RGB Limited checkbox. Toggle that and see what happens. There was a thread in the Kodi forums about this but I can't seem to find it. The hardware and software are more than capable enough to get a great picture; it's all in the setup.
 

poofyhairguy

Lifer
Nov 20, 2005
14,612
314
126
In Kodi, go to the Settings tab->System->Video, make sure you have Expert Mode enabled (at the bottom of the menu in the Confluence skin), then find the RGB Limited checkbox. Toggle that and see what happens.
Yup, that was what I was going to say. Looks like a color space issue to me.
 

phillyman36

Golden Member
Jun 28, 2004
1,604
48
91
I checked the RGB Limited box and it did get better but still not as good as the Dune. Funny thing is I just got a Skylake NUC (nuc6i3syh) and the picture quality is on par with the Dune. No adjustments needed. Both have the latest drivers and Windows 10 installed(Mind you the Broadwell NUc has 8gb of ram and the Skylake NUC has 16gb of ram.)
 
Thread starter Similar threads Forum Replies Date
skyking Home Theater PCs 0

ASK THE COMMUNITY