Not happy with Newegg

JE78

Golden Member
Jun 6, 2004
1,418
0
71
Last monday 8/15 I RMAed a stick of RAM to Newegg via USPS First Class Mail with Delivery Conf. On friday 8/19 I check the USPS website and it said it was delivered. A few days go by and I hear nonthing and the status of my RMA was still on step 1. Yesterday I e-mailed them asking if everything was ok and if there was a problem. This morning I wake up to an e-mail telling me they have not received my package. :l So they asked me for the confirmation number and I sent that to them. Well then I got to looking over the e-mails Newegg sent to me when they gave me my RMA number and realized they told me to send it too two different addresses. The first e-mail I got was the one with the shipping lable they tell you to pint out. The address is:
Newegg.com
132 South 6th Ave
La Puente, CA 91746-3026

Followed by my customer# and and RMA#. Then I got another e-mail with that says to send it to this address:

Newegg.com
9997 E. Rose Hills Rd.
Whittier, CA
90601

Well I had already printed out the label from the other one because thats what it said to do and put that on a box and shipped it out. So now I don't know what to do. I have to wait for Newegg to find my package which is really not making me happy. Just wondering which address I should've shipped it too?
 

ecosvaldo

Member
May 24, 2005
32
0
0
The address you're suppose to ship your item to is the one in Whittier, CA. I had to RMA one of my items back to Newegg on 8/16. They received it on 8/18 and shipped the replacement on 8/19. Got my package on 8/23.
 

JE78

Golden Member
Jun 6, 2004
1,418
0
71
Well why would they send me an e-mail with an RMA label with La Puente, CA, tell me to print it out and send it to that one. Then send me another e-mail and tell me to send it to another place but I had already sent it to the other place?????? Not amused at all