Question No sound from H310 Realtek Audio driver

torlen11cc

Member
Jun 22, 2013
143
5
81
Hi everyone,

I've been wrestling with a driver issue for a couple of days now, so thought I'd post here and see if anyone can help.
I am using a H310CM-HDV/M.2 motherboard, with an Intel i5 9400F CPU. Until recently I have been using the sound provided by HDMI from my GPU, however I want to be able to use my rear panel audio ports for speakers.
I downloaded and installed the drivers and Realtek Audio HD app listed on the H310CM-HDV/M.2 download page (https://www.asrock.com/mb/intel/h310cm-hdvm.2/index.asp#Download).
No sound can be heard.
I can confirm that my speakers is functioning correctly, having tested it on another system.
I have undertaken every step found at https://support.microsoft.com/en-us/help/4520288/windows-10-fix-sound-problems, but to no avail.
I'm at a loss at what else to try, does anybody have any advice?
 

Insert_Nickname

Diamond Member
May 6, 2012
4,695
1,283
136
Checked to see if the default audio output device is set to the Realtek device?
Indeed. The default may still be the HDMI output. You have to manually change it each time to the Realtek's output upon restart. Be aware changing audio devices is a bit more convoluted under Windows 11 then under 10.

If that does not work, try to completely remove the audio drivers. Then remove the Realtek sound device from device manager. Restart and let Windows Update install the default driver, then change output to Realtek speakers.
 
  • Like
Reactions: torlen11cc

igor_kavinski

Diamond Member
Jul 27, 2020
3,809
2,270
106
Do you have headphones plugged into the front panel? If so, it says right there to disable the rear output ports, which is where you have presumably connected the speakers. Remove the headphones jack from the front panel port and see if the greyed out Back Panel under ANALOG becomes available.
 

lakedude

Platinum Member
Mar 14, 2009
2,490
220
106
What is "disable front jack detection"? Maybe try switching that off?

Those back panel connections being grayed out is more than a little suspicious...
 
  • Like
Reactions: igor_kavinski

lakedude

Platinum Member
Mar 14, 2009
2,490
220
106
Can you try the speakers plugged into the front?

Are the rear connections disabled for some reason?

I have should have had 3 sound options but Oculus was disabled so I only had 2. Had to manually switch Oculus sound on to make it available.

Are you sure the correct front panel audio connector was used? For some reason there are 2 standards so cases come 2 different connectors. I've done this wrong before and stuff got hot! Not sure why front panel would mess up back panel but it is something to check.

Bluetooth is another way for sound to avoid the traditional routing...
 

ASK THE COMMUNITY