New gfx card on Abit-KT7A

Jan 10, 2003
61
0
0
Hello!

I once again look for people with experiences with the infamous Abit KT7A.

I'm about to uppgrade my KT7A (version 1.3) with a new grafic card, but have come to second thoughts when I heard about people having problems with the mobo dont accepting new cards.

So, is there anyone out there who has tried newer gfx cards on the KT7A ? ? ?

I'm looking for both good and bad experiences.

Thanks!
 

Powersupply

Member
Oct 19, 2001
54
0
0
Hello there!
Yesterday I tried to install my new Sapphire Radeon 9500 non-pro 128Mb graphics card onto my rev 1.0 Abit KT7A. Problems.
I got artifacts and after about 15 sec in windows my mousepointer dissappeared. Tried to reinstall everything but nothing worked.
I was thinking maybe I got a defect card.

Then I tested the card on my other computer with a MSI board and it worked without any artifacts at all.

Just a bit of info
/ PowerSupply
 

BoomAM

Diamond Member
Sep 25, 2001
4,546
0
0
If your getting a 9700 or a 9700pro, ensure that the board revision(of the 9700), is revision3.0, as this fixes any compatibilites with the card.
Also, make sure that you have the latest BIOS, and you should be fine. I think the latest BIOS for revision 1.3 fixes problems with GF4 Ti cards.
It should work fine. Any Problem you have, just make a post and you`ll get a reply, and more often than not, answer to the problem.
 

Actaeon

Diamond Member
Dec 28, 2000
8,657
20
76
I've only tried a TNT1 and a GF3 Ti200 on my older Abit KT7A V1.3. Worked flawlessly
 
Jan 10, 2003
61
0
0
OK, thnx for your help.
I think I will go for a Radeon 9100 which is said to be just a new name for the Radeon8500.

So, is there anyone out here who have tried the Radeon 8500 together with KT7A v1.3?
 

ASK THE COMMUNITY

TRENDING THREADS