• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question New Build - Powers up, stays on, but no display

ungerdog

Junior Member
May 4, 2020
2
0
6
I am working on my first build.

Parts List:
Processor: AMD Ryzen 5 3600
Motherboard: ASRock ATX B450 Pro4
GPU: Radeon Rx 590 Fatboy 8GB
RAM: Corsair Vengeance LPX DDR4 8 (x 2)
Power Supply: Corsair CX Series 550 Watt
Storage: Crucial P1 1TB

The system turns on, the case fans come on, no audible beeps (but no speaker to do so) and lights come on the graphics card, but I get nothing on the monitor. I've seated and re-seated all components and cables.

I've used multiple monitors and multiple HDMI and Display Port cables. I am plugging the cables into the graphics card, not the motherboard.

The bios stamped on the motherboard says p3.90 released in December 2019. ASRock says p3.20 released in May 2019 is required for 3rd gen AMD processors. So there seems to be no need to update bios since I have a later version.

The graphics card has proper power cable connections (8 pin and 6+2 with the 2 ignored) and has one red light and one blue light on it when the pc is on. I cannot find any description of what those lights mean, but the red light concerns me and makes me wonder if I need a bigger power supply. However, I did switch the graphics card to a Evga Nvidia Geforce GT 1030 which requires far less power and is also compatible with the motherboard. I got the exact same results with the Nvidia and the Radeon card. No display. The fans on the graphics card do move.

I took out one of the memory cards and put the single memory card in slots A1, A2, B1 & B2 with the same results each time.

At this point, I am at a loss as to what could be the issue. I don't know what else to do other than to start buying replacement components 1 at a time until I find the issue. Please help.
 

VirtualLarry

No Lifer
Aug 25, 2001
50,797
6,265
126
If all else fails, put ONE stick of RAM in A2, put in the lowest-powered GPU you have (since your CPU doesn't have onboard graphics). Which, in your case, would be the GT1030. Then, unplug the system from the wall, and find your CLR_CMOS jumper on the mobo. If it's a 2-position header, jumper it with a jumper (if you have one handy), otherwise, short with screwdriver for 10secs. If it's a 3-position, move it from "normal" to "clear", wait 5 seconds, then move it back to "normal".

Also, make sure that you have a beeper (peizo speaker) properly attached to the 4-pin "SPKR" header (usually near the front-panel header).

Then, re-plug, and attempt to power-on. Initial POST after a CMOS clear, or initial bootup with a new CPU, or possibly new RAM, can take sometimes nearly two or more whole minutes. I would be patient and wait five, if you have to.

If you get beeps, look up the beep codes. If your mobo has "Diag LEDs", then look those up too.

Don't have any storage connected at this point. Just RAM, GPU, CPU, mobo, and power, and power-on / reset / power-LED / HDD-LED.

If this is a really high-end board, such as some X470, many X570, it may have more than just an 8-pin ATX12V/EPS12V CPU power connector in the upper-left corner of the board. It may have an 8+8, or an 8+4. Some boards will not post without BOTH connectors occupied.
 
  • Like
Reactions: ungerdog

JustMe21

Senior member
Sep 8, 2011
322
47
91
Also, try pulling the CMOS battery for about 10 seconds. I had a wierd issue with an ASRock motherboard where the keyboard and mouse wouldn't work and that solved the problem. But you definitely need an internal speaker in case there are any POST beeps.
 

ungerdog

Junior Member
May 4, 2020
2
0
6
Thanks for the help. The graphics card wasn't fully plugged in. There are two 8-pin ports for power on the card. Every instruction I saw said to plug in the 8-pin and the other will be in 6+2 configuration, just plug in the 6 and leave the 2.

I finally plugged in the 2 which gave me 8+8 pin and everything worked.
 

ASK THE COMMUNITY