New 6870 - low fps on Crysis

B00M123

Member
Apr 11, 2011
76
0
0
Just got a new gaming computer with a Sapphire 6870. On Crysis on very high in 1080p with 2xAA I only get 20-30fps. In benchmarks and online I have seen others that get 30-40fps constant. Why is my fps so low? Also, it is very irregular. So if I look one way I get 40fps then when I start moving I get 20fps. Why is this? I'm downloading patch 1.2 to see if this helps, no idea how to install it (bit of a noob).
 

B00M123

Member
Apr 11, 2011
76
0
0
AMD Phenom II X4 955 Black Edition
Microsoft® Windows 7 Home Premium 64-bit
Asus M4A87TD USB3
4.0GB Corsair DDR3 1600mhz XMS3 CL9
650W Corsair TX Ultra-Quiet
 

Bryf50

Golden Member
Nov 11, 2006
1,429
51
91
For 1080p very high and 2xAA that sounds about right.
Here is your card in Warhead but on a faster i7 test system:
33214.png

33217.png

Warhead is a bit more optimized than Crysis and they're running the equivalent of high setting with very high shaders.
 
Last edited:

cusideabelincoln

Diamond Member
Aug 3, 2008
3,268
11
81
The patch for Crysis does help some performance.

What you're getting doesn't sound too unreasonable. Different parts of Crysis are more demanding than what benchmarkers could be using.

Crysis is only threaded for two cores. Your processor is holding back performance slightly.

Outdated drivers, or not reinstalling the drivers when installing the new card, can result in not-optimal performance.

All of these little things will add up. You should probably first drop the texture settings down to High instead of Very High. Then tweak the other settings until you get satisfactory performance.
 

B00M123

Member
Apr 11, 2011
76
0
0
Ok cheers Ill try that. I just downloaded the patch and installed it using the install wizard. Is the patch now installed? The version was 1.2 which I think is the latest?
 

B00M123

Member
Apr 11, 2011
76
0
0
Just wondering if I have some setting in the catalyst control center holding the performance back? Also, should I put the GPU fan up to 100% as its only at 30% now?
 

B00M123

Member
Apr 11, 2011
76
0
0
I just have it set on "use application setting". What about the fan speed, should I leave this at 30%?
 

betasub

Platinum Member
Mar 22, 2006
2,677
0
0
^ Fan speed should be left on AUTO (unless it is not controlling properly). Of course, you are free to turn it up to "hairdryer" setting if your ears can stand it :)
 

B00M123

Member
Apr 11, 2011
76
0
0
Ok thanks for all the info everyone. But could you answer my question about the patch, I went through the install wizard so is Crysis now running 1.2?
 

notty22

Diamond Member
Jan 1, 2010
3,375
0
0
Right click on the .exe in windows explorer. Under details it will tell you the version.
 

ActionParsnip

Junior Member
Apr 15, 2009
8
0
0
Make an autoexec file, plop it in your crysis game folder, put these lines in that file:

con_restricted=0
r_displayinfo=1
sys_spec_Full=4

________________________

e_precache_level=1
e_particles_thread=1
gpu_particle_physics=1
sys_physics_CPU=2
r_MultiGPU=2
r_TexturesStreaming=0

r_GeomInstancing = 1
es_ondemandphysics = 1
r_CullGeometryForLights = 1
e_vegetation_static_instancing = 0
e_terrain_occlusion_culling = 1
e_terrain_occlusion_culling_version = 0
e_terrain_occlusion_culling_max_dist = 200

Hey presto some of your cpu limit is taken away, more of the game is preloaded into your ample ram capacity, and your game will feel and run smoother as a result.
 

B00M123

Member
Apr 11, 2011
76
0
0
Cheers. The patch has made it run much better, rarely goes below 30fps now =D

ActionParsnip - what will those do? I know one shows my fps. Not too sure what folder I'd put it in or how to create that file type.