• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Question Netgear Nighthawk R7000 5GHz network stops working when my brother drives away!

Ichinisan

Lifer
Oct 9, 2002
28,298
1,228
136
This is bizarre. It's always backed-up by Nest camera footage.

1. My brother leaves the house and drives away
2. then the Nest camera goes offline.

At first I thought it was a problem with the camera. Now I realize it's the 5GHz WiFi network.

It happened again when he left for work a little while ago. This time I noticed first that the connection on my laptop stopped working. I checked the Nest camera and saw that, once again, it went offline immediately after my brother drove away. My Windows desktop computer had somehow switched to 2.4GHz. It had already been running a continuous ping out to 4.2.2.2, showing no disruption. I tried switching it to the 5GHz network. It failed to connect and switched back to 2.4GHz. Ping replies resumed as soon as it reconnected to 2.4GHz. Meanwhile, my laptop remained disrupted until I switched it from the 5GHz network to 2.4GHz. The 5GHz band started working again after 22 minutes. I'm not sure if something I did (logging-in to check firmware, etc) may have kicked it. This time I did not power-cycle the router.

Has anyone ever heard of an issue like this? It wouldn't be a MAC or IP conflict because that would affect both wireless bands (and wired connections too).

The Netgear Nighthawk R7000 router is currently running "V1.0.9.88_10.2.88" firmware and reports there is no update available. My brother's mobile device is a Samsung Galaxy Note 9.
 

CZroe

Lifer
Jun 24, 2001
24,185
845
126
While it does seem to happen more often when my Samsung Galaxy Note9 goes out of range, it also happened when our friend and his wife left Saturday night (iPhone users) and when you left Thursday morning (another iPhone), so it's not exclusively when I leave and doesn't seem to be specific to my device. I very often manually toggle off my phone's Wifi when leaving since the phone trying to hang onto a weak connection sometimes disrupts my phone's data connection for miles. Perhaps that increases the chances of this happening, but it only started happening about a month ago and I've been using the phone the same way for a year and a half.
 

mxnerd

Diamond Member
Jul 6, 2007
5,939
815
126
Use different SSIDs for 2.4G and 5G probably can solve the issue.

===

Or if you are brave enough, try FreshTomato firmware. (not that hard)


Your router's firmware.

https://freshtomato.org/downloads/freshtomato-arm/2020/2020.8/
https://freshtomato.org/downloads/freshtomato-arm/2020/2020.8/K26ARM/

discussion:
 

MtnMan

Diamond Member
Jul 27, 2004
5,933
4,156
136
Have him turn his phone off while he is home. What happens? Does he carry any other device with him when he leaves, tablet, laptop?
 

CZroe

Lifer
Jun 24, 2001
24,185
845
126
Have him turn his phone off while he is home. What happens? Does he carry any other device with him when he leaves, tablet, laptop?
I turn the phone's WiFi off pretty frequently and it doesn't seem to cause an issue. I think it has something to do with Nest Aware doing something that crashes the 5GHz side of the router every time the camera sees someone leave.
 

MtnMan

Diamond Member
Jul 27, 2004
5,933
4,156
136
I turn the phone's WiFi off pretty frequently and it doesn't seem to cause an issue. I think it has something to do with Nest Aware doing something that crashes the 5GHz side of the router every time the camera sees someone leave.
Not your phone, his phone.

Have him sneak out the back door ;)
 

CZroe

Lifer
Jun 24, 2001
24,185
845
126
Not your phone, his phone.

Have him sneak out the back door ;)
Well, my phone is the one the OP is questioning and the one that seems to trigger it most often... if it is a phone and not Nest Aware. :)

Nest Aware does have some user-specific settings but I've checked everything. I even toggled back and forth on anything relevant just to make sure Google/Nest's cloud settings are in-sync with what I'm seeing on my device. Still, this behavior started randomly one day a month or so ago, as if the Nest camera got a silent update or something on the server side changed.
 
Last edited:

Ichinisan

Lifer
Oct 9, 2002
28,298
1,228
136
Use different SSIDs for 2.4G and 5G probably can solve the issue.
Separate SSIDs are used. That's why I was able to switch bands while troubleshooting.


Or if you are brave enough, try FreshTomato firmware. (not that hard)


Your router's firmware.

https://freshtomato.org/downloads/freshtomato-arm/2020/2020.8/
https://freshtomato.org/downloads/freshtomato-arm/2020/2020.8/K26ARM/

discussion:
Yeah. I will try custom firmware. I found other users complaining of unstable 5GHz band using the latest official firmware. Apparently this has been going on for a very long time, and the only solution is still to downgrade to an old firmware (possibly re-introducing various security vulnerabilities).
 
  • Like
Reactions: Ranulf

manly

Diamond Member
Jan 25, 2000
8,833
434
126
Not to derail this thread, but there was a time when I wouldn't consider a Netgear router but their reputation has improved over recent years and I did end up deploying two of them over that time period due to strong value proposition. The old router was a Belkin 802.11n router running ancient Tomato firmware, but it was rock solid for many years. It had NO external antennas, but gave decent enough range into the backyard.

The newest router is an R7200 and it's been good, but with one issue. When I use the router's internal DNS resolver (a caching nameserver), the service sometimes craps out and DNS lookups take a very long time (in the order of 20-30 seconds). It would happen randomly and not quite frequently enough to be a show-stopper. I found a few threads on the Netgear forums that reported similar problems, but no definitive solutions. Anyway, I changed my laptop's config to use Cloudflare and Google for DNS and the problem went away. Apparently I didn't hard-code static DNS resolvers on the router itself so it's likely that my problem was host-specific.

Anyway, I'd be a little wary of buying a Netgear router again in the future but glad to read that Tomato is still an option!
 
  • Like
Reactions: CZroe

mxnerd

Diamond Member
Jul 6, 2007
5,939
815
126
The newest router is an R7200 and it's been good, but with one issue. When I use the router's internal DNS resolver (a caching nameserver), the service sometimes craps out and DNS lookups take a very long time (in the order of 20-30 seconds
Factory firmware or Tomato firmware?

There is no internal DNS resolver for factory firmware.

It just forwards its DNS queries to your ISP's DNS servers assigned by the WAN DHCP.
 
Last edited:

manly

Diamond Member
Jan 25, 2000
8,833
434
126
Factory firmware or Tomato firmware?

There is no internal DNS resolver for factory firmware.

It just forwards its DNS queries to your ISP's DNS servers assigned by the WAN DHCP.
Factory firmware.
Right, it uses the ISP's nameservers but the router is clearly running a daemon for this service. This has always worked well on the previous router, and actually it seems to work fine on most clients. It's possibly some interaction between an application on a particular device, but 20-30 second hangs for DNS queries are really annoying. And they did not occur before I replaced the ancient router.

Here are the forums URLs I ran across for years-old issues. I'm guessing these are relatively isolated incidents.

 
  • Like
Reactions: Ranulf

mxnerd

Diamond Member
Jul 6, 2007
5,939
815
126
I see.

FreshTomato is definitely a choice if the factory firmware is not working well and the device is supported.

Worth a try.
 

Fallen Kell

Diamond Member
Oct 9, 1999
5,595
224
106
I run DD-WRT on my R9000 (in AP mode and providing DNS and DHCP to my much larger network connected to my core network via 10Gbe), but I have not seen a lot of good info on the R7000 with DD-WRT at least. I have seen the R7800 with DD-WRT being excellent (even better than my R9000 in terms of features working). The R9000 has some quirks with VLANs, which "can" be done, but are very tricky and may easily result in needing to factory reset when attempting to configure due to the physical hardware (there are 2 internal switches, both of which need to have the VLANs added to the internal connections between the two switches in the proper order, otherwise the link between the switches gets disrupted and you can not pass commands to the other switch in order to send it configuration information or send/receive network packets from devices connected to that switch). The R7800 does not suffer that problem as much and the web interface can fully configure VLANs. The R9000 requires command line startup scripts in order to perform the same thing (which is where people tend to screw up if they did not first test via command line, and simply set them as a startup script, only to find out that they had some bad syntax/command ordering and can't communicate with the web interface because their connection was going through one of the internal switches that is borked, requiring a factory reset and wiping of all configuration on the router).
 
  • Like
Reactions: CZroe

Ranulf

Golden Member
Jul 18, 2001
1,656
175
106
Glad I came across this post. I've been having wifi and even wired connection issues off and on for over a year on a r7000. They'd gotten better since upgrading to the newest NG firmware a couple of months ago (previous firmware had improved but was still rando dropping wifi). The biggest problem was a laptop that would lose connection a lot or lose access to the internet but not the local network. I figured it might just be the laptop and/or win10 often when the machine was coming out of sleep mode.

A few weeks ago I took offline I think the last machine (an ipod) using the 2.4ghz signal regularly and I haven't noticed any drop outs on the win10 laptop since. Knock on wood.
 
  • Like
Reactions: CZroe

Jenova314

Senior member
Dec 3, 2000
792
0
76
I run DD-WRT on my R9000 (in AP mode and providing DNS and DHCP to my much larger network connected to my core network via 10Gbe), but I have not seen a lot of good info on the R7000 with DD-WRT at least. I have seen the R7800 with DD-WRT being excellent (even better than my R9000 in terms of features working). The R9000 has some quirks with VLANs, which "can" be done, but are very tricky and may easily result in needing to factory reset when attempting to configure due to the physical hardware (there are 2 internal switches, both of which need to have the VLANs added to the internal connections between the two switches in the proper order, otherwise the link between the switches gets disrupted and you can not pass commands to the other switch in order to send it configuration information or send/receive network packets from devices connected to that switch). The R7800 does not suffer that problem as much and the web interface can fully configure VLANs. The R9000 requires command line startup scripts in order to perform the same thing (which is where people tend to screw up if they did not first test via command line, and simply set them as a startup script, only to find out that they had some bad syntax/command ordering and can't communicate with the web interface because their connection was going through one of the internal switches that is borked, requiring a factory reset and wiping of all configuration on the router).
Looks like I might be running into the scenario you just described. I just got an r9000 off eBay. Transferred most of the settings from my previous r6700. However, WiFi devices are having a hell of a time trying to connect to the 802.11ac 5GHz radio... sometimes it works if I put it into 802.11ac/n mixed mode, but I can't seem to be put my finger on it. There's no one setting that seems to be the determining factor, so it's happening almost randomly each time new settings are applied.

How should the VLANs be setup?
 

Fallen Kell

Diamond Member
Oct 9, 1999
5,595
224
106
It all comes down to your network as to how you should setup VLANs. You don't need them unless you are trying to segregate various wireless or wired devices from other devices.

Now my setup a going to be different from most as I am not using the R9000 as a router, but just a wifi access point. Also important is that my R9000 is connected via the SPF+ port, and not a standard RJ45 to my core network (VLANs work fine on this interface, but the others are much more complicated). My core network switch does all the inter-VLAN routing (that I allow), and my edge router does the routing to the internet. I setup two additional VAPs (virtual access points) on each of the 2.4 and 5GHz bands. This is done in DD-WRT under the wireless page, by clicking on the "Add" button under "Virtual Interface" after each of the radios (there are several tutorials/how-to's on this for how to create a guest network under DD-WRT, make sure you check the "AP Isolation" option on them). Once you have the virtual interfaces, you can create the additional VLANs by going under the "Setup"->"Networking" tab and adding the VLAN tagging to eth0 (which is the SFP+ port). You can use any VLAN ID you want/need, except for 1 or 2 as they are already in use by the router and can cause problems if you do not already understand that they are in use and what they are being used to do. You will now need to create new bridge devices for each of the groupings of devices you want to have (in my case, I have 2 additional bridges, one for a "guest" network, and one for "internet of things" devices) under "Bridging" section on the same page. Under the "Current Bridging Table", you want to make sure you remove the new VAP interfaces, the additional eth0.<vlan id> devices, and additional bridges from the "br0" bridge (otherwise they are all just one network). Save the settings, and reboot the router (at this point, you have not done anything that will cause problems).

After it reboots, you need to go back to the "Wireless" tab and configure the new VAPs that you created (if you didn't do that already), basically you are just setting a new SSID and encryption keys (it will use the same bands and other physical network settings as the original device). Now under the "Setup"->"Network" tab, you can configure the eth0.<vlan id> interface, giving them an IP address and netmask (defining the network for the VLAN). These need to be different from each other, otherwise it will not be able to route them correctly. I suggest simply using the VLAN ID as the third octet in the subnet (so 192.168.<VLAN ID>) and if the R9000 is going to be your router, I suggest making the IP of the eth0.<vlan id> be 192.168.<VLAN ID>.1 (if it is not going to be the router, you can make it .2 or .254).

Now comes the tricky part, assigning the VAPs and eth0.<vlan id> to the new bridges that you created. This is where I had to use a startup script under "Administration"->"Commands". ABSOLUTELY DO NOT SIMPLY PUT AND SAVE THE STARTUP SCRIPT UNDER HERE THE FIRST TIME! You need to test it, preferably via a "ssh" connection to the router and running the commands directly there and verifying first.

As a startup script I have the following:
vconfig add eth0 8
ifconfig eth0.8 up
ifconfig eth0.8 txqueuelen 1000
brctl addif br1 eth0.8
brctl addif br1 ath0.1
brctl addif br1 ath1.1
vconfig add eth0 10
ifconfig eth0.10 up
ifconfig eth0.10 txqueuelen 1000
brctl addif br2 eth0.10
brctl addif br2 ath0.2
brctl addif br2 ath1.2

I used VLAN ID 8 and VLAN ID 10 as my "guest" and "IoT" VLANs. The above sets up the appropriate VAP devices and VLAN tagged eth0 devices into bridge device br1 and br2 respectively. If you are only setting up one VLAN, you don't need the lines that repeat. The "vconfig add eth0 8" is adding the VLAN ID 8 to eth0 correctly. The next line "ifconfig eth0.8 up" brings the new tagged interface device online. "Ifconfig eth0.8 txqueuelen 1000" sets a transmit queue length of 1000 to the device (a performance option). "Brctl addif br1 eth0.8" adds "eth0.8" to the "br1" bridge. "Brctl addif ath0.1" adds the 2.4GHz ath0.1 VAP device to the "br1" bridge. "Brctl addif ath1.1" adds the 5GHz ath1.1 VAP to the "br1" bridge.

Again, if you use different VLANs, you should change the vconfig add eth0 line as appropriate.

After you have run those command manually via ssh or the command interface, you should see under "Setup"->"Networking" in the "Current Bridging Table" the br0, br1, and br2 (at least if you setup 2 VLANs) and see the correct devices under each. You should not see the eth0.XXX, ath0.XXX, ath1.XXX under br0, and only see them grouped together under the new bridge devices. You should also see under the VLAN Tagging that eth0 has the new tags.

If this all looks correctly you can save it as a startup script under "Administration"->"Commands" "Save Startup script".

Do not attempt to change the VLANs under the "Setup"->"VLANs" page. Simply ignore that page entirely, it will only cause problems and possibly require you to factory reset.

There are additional settings you need to make if you are using the R9000 as the router. You will want to block access anything from 192.168.<VLAN ID>.XXX going to 192.168.1.XXX. You will also want to block ssh, http, and https from 192.168.<VLAN ID>.XXX from going to 192.168.<VLAN ID>.1 (or whatever you setup the R9000's IP address on the eth0.<VLAN ID> interface). You will need to read up on that from a tutorial.

You will also want to define additional DHCP address spaces for the new VLANs. Again, you can read how to do that on a tutorial for DD-WRT.
 
  • Like
Reactions: CZroe

ASK THE COMMUNITY