Need some help with Routing


Diamond Member
Oct 16, 2001
Ok folks, I'm about ready to completely give up & pay for yet another static IP, but I really don't need one. Let me give you an overview of what I'm trying to do along with my network structure. I'll do the structure first:


1 Cisco 675 DSL router
1 8 port 10/100 switch
1 Wireless Access Point
4 PCs total on network (1 on wireless)

Operting systems:

1 client running Windows 2000 Pro
2 clients running Windows 98 SE
1 client running Mandrake Linux 8.0

Address configuration

Windows 2000 machine static IP on network
Windows 98 machines static IP on network
Mandrake Linux machine static IP on

What I'm trying to do:

Allow all clients to access the fileserver that is on the address but I cannot seem to do it. Here's what I've tried:

Approach 1:

This approach I setup the Cisco 675 to do DHCP & NAT, problem was that it would not work properly as a DHCP server for some odd reason. I went through several newsgroups & a cisco chat room and after a bit of tweeking I had the configuration correct but it would not hand out addresses to either the Windows 98 client or Mandrake Linux client. I could understand that I might've misconfigured DHCP on the mandrake client but the Windows 98 client is as easy as it gets. It was not getting a response from the DHCP server (Cisco 675) so that approach went out the window

Approach 2:

This time I decided to stick with just plain old routing, the Mandrake client doesn't need access to the internet really I just need to access it over the network. But I could not seem to get routing to work either. I've set eth0 to and vip0 (virtual IP) to as I was told it would then automatically route the packets. It did not, tried switching them around with the same results. I then figured I should probably add them to the routing table for the clients, first up was the Windows 2000 client, I typed in the following (the x's have numbers):

\F:\>route add mask
The route addition failed: The specified mask parameter is invalid. (Destination
& Mask) != Destination.

I tried it with a mask of with the same error message, any ideas of what's wrong here?

If you have a solution to my problem (no I don't want to change all of my IPs to private addresses) that will allow me to access my fileserver I will be grateful. Thanks.



Junior Member
May 1, 2002
hrmm ok, where to begin...

first your route add command. "route add mask", the 216.98.x.x entry should either be the ip address of the machine your entering it on or the ip address of the eth0 interface. try a mask of, there is no need to use a custom mask of 252 on an internal network of that size. also the main reason why your route add did not work is because of the first ip entry, the destination network. you cannot enter a specific address(host) into this entry, it has to be a network ID address, like Using will give you the error your getting. so use with a mask of that should fix that. but hoenstly you should not need that route if those machines have default routes setup already that point to the eth0 int on ur dsl router. the default route will be displayed as gatewayIP in the route print screen. this basically tells your windows machine to forward all unreconized traffic, traffic that does not have a specific route, to your router(which should be your gateway).

can the clients on your 216.98.x.x network ping the 192.168.x.x vip0 int on the router? can the router ping all clients on both networks?

i would try and enter the "ip classless" command on your dsl router. not sure if that will help but it could. also instead of using the vip0 int try using a secondary int on the router. i havent really played on that type of dsl router before so i dont know if it would have the ability to create secondary interfaces. to create one simply go into config t, and type "int eth0.2" then assign an ip address etc...

also make sure the mandrake machine has the proper routes so it can also see other networks. im not a linux person so i cant really help you on how to check or set that part up. sorry =\

i know you dont want to make everything an internal address, but for troubleshooting purposes its 100 times easier to pinpoint a problem when everything is on the same network. personally i would setup every machine to have the same address range. if that works then 1 by 1 i would move to the multi network setup u want.

let me know what happens! =]