Need help with possible cause (which part to replace) - CPU or Mainboard?


Senior member
May 5, 2001
Hi Folks,

Been a long time since I popped on here, so apologize for that but wanted to get some experience input on what could be the possible cause to an issue I am having.

System Specs:
Ryzen 5 1600
Mainboard: Gigabyte GA-AB350 Gaming 3
RAM: Corsair LPX 16 GB 2400 Mhz DDR4
Video Card - 7300GT
HDD/SSD: Crucial - 120 GB SSD
OS: Ubuntu Server

Issue: I have 16 GB of DDR 4 RAM installed, can see that in the bios. However in the system (Ubuntu Server, Linux Mint, Proxmox) I can only see 7.7GB of memory.

What I have tried:
  1. Reseated the RAM
  2. Booting with a sinlge stick of ram in each memory slot to see if the ram was the issue or the slot was the issue
  3. Reseated the CPU
  4. Booted into a Linux Mint Live USB and did free -h
  5. lshw -c memory shows 16 GB but free -h, ubuntu, linux mint and proxmox still only show 7.7 GB
  6. cat /proc/meminfo shows only ~8GBs
    MemTotal: 8086184 kB
    MemFree: 6660220 kB
    MemAvailable: 6815084 kB
  7. I tried to install and boot another chip I had (3800x) but the AB350 wasn't accepting it (probably a bios version)
  8. Install 16 GB of DDR 4 @ 3200 Mhz from another sysetem with no change
  9. Upgraded the Bios
Any thoughts on a possible cause - I think the mainboard my be the problem....but when I had the 1600 CPU in another board previously Windows showed all 16GB of RAM, but that was a different set of RAM. So I am second guessing myself as to the problem here. Could a CPU memory channel be fried and that is why the mainboard sees 16 but the OS only sees 8?
Last edited:


Senior member
May 5, 2001
Found the problem and it has happened to a few others out there. The GA board + 1600 combo for some reason has a setting (wasn't able to find) where half the system memory is reserved. Windows and Linux clearly show this. When I swapped the CPU out for my 3800x the reservation went away, but the board failed to post evertime with the 3800x chip (even after flashing with the latest bios) Moved the 1600 chip to my son's system (low end gamer) and took the 3800x for my linux rig.