Need help! New 8TB hard disk not being initialized.


Junior Member
Mar 18, 2020
I made my PC a year ago and it runs great. I had purchased a 4TB Toshiba X300 internal HDD for it and it works flawlessly. Recently I decided to add a new HDD in addition and went for 3.5'' Toshiba X300 8TB. But the problem is that my PC is not picking it up. It is being shown as "Unknown Not Initialized" in disk manager and doesn't event show the capacity. Furthermore, if I try to initialize it, it shows "A device which doesnot exist was specified" error. In my BIOS sometimes it would show up as detected but as a 4TB one. I updated my BIOS, all the drivers and then it started to show up as 8TB but that doesn't solve the issue still. I checked all my cables, used new ones, tried installing windows on it(can't because it doesn't show up), heck even Ubuntu because I thought maybe it was a Windows issue. I can not use any software since it doesn't event show up anywhere. This is the 2nd time it is happening(I bought one(same) and returned one already because it was giving me the same error). I have tried everything to my knowledge and still don't know what the issue is. I think its my Motherboard that doesnt support more than 4TB but that doesn't make any sense. Bios is running in UEFI mode and yes I am trying to use GPT.Any help would be appreciated.
My PC specs:
Thanks alot!