• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

Need for Speed Hot Pursuit, Black Screen on startup?

Nebor

Lifer
Jun 24, 2003
29,582
11
76
So I bought NFS Hot Pursuit for $5 or $10 during a Steam sale a couple weeks ago. I plug in my xbox 360 controller and get ready to play and I'm presented with a black screen on startup. Nothing happens. Ever. I let it sit for 4 hours. It never starts.

So I start furiously googling away, and I find some advice. Following that advice I updated my video card drivers, motherboard drivers, directx runtime, set the game to run as an administrator and set it to run in XP SP3 compatibility mode. And it worked! I played it yesterday and it was pretty fun. I especially like the "be the cop" mode. Reminds me of the old hot pursuit games.

But here's the tricky part, I can't get it to start again. It only worked the one time. I didn't change anything, didn't even restart the computer. Now there's nothing I can do to get it to work. I tried lowering the startup resolution, but that didn't help. I'm just greeted with a blank screen on startup. I kind of expect more out of Steam.

System is Windows 7 64 bit, i7 2600k, gtx 295 and 8gb of ram.

Any ideas? Anyone experience the same problem?
 

Nebor

Lifer
Jun 24, 2003
29,582
11
76
The game was recently updated to the newest version on Steam, but it didn't solve my problem. The game just sits at a black screen on startup. I posted on EA's support forum, but the only thing there are more people like me. :(
 

busydude

Diamond Member
Feb 5, 2010
8,793
4
76
Have you tried disabling SLI?

I am not sure about that.. but it is worth checking out.. IF you haven't until now.
 

Monster_Munch

Senior member
Oct 19, 2010
873
1
0
I've fixed some problems like this by starting the steam client as administrator before launching the game.
 

ASK THE COMMUNITY