Need bios for HIS RX 480 IceQ X² 4gb card

ubern00b

Member
Jun 11, 2019
171
74
56
post a GPUZ screenshot of the card and/or if possible a pic of the white stickers on the back of the card with the S/N
 

ubern00b

Member
Jun 11, 2019
171
74
56
I need this info for the subsystem and device id information to make sure I find you the correct bios
 

testerr86

Junior Member
Jun 28, 2019
17
2
11
post a GPUZ screenshot of the card and/or if possible a pic of the white stickers on the back of the card with the S/N
Here's a screenshot but the bios and the details that you see are not correct. I decided to flash my bios yesterday and downloaded an unverified bios from GPUZ and got into trouble.
I get display and everything but the problem is right after driver installation it, my screen either goes black or white and freezes.
 

Attachments

testerr86

Junior Member
Jun 28, 2019
17
2
11
I even bricked my graphics card today while trying to fix this problem but somehow managed to unbrick it later on, and was forced to use the same corrupt bios which is causing this problem.
 

ubern00b

Member
Jun 11, 2019
171
74
56
Are you certain your memory chips are elpida have you verified this by looking at the actual chips (ie: removed the cooler)
 

ubern00b

Member
Jun 11, 2019
171
74
56
You need to physically inspect them by taking the cooler off. There are only 2 other bios files for the 4gb version of your card (apart from the one you flashed) both are hynix, but they share the same subsystem and device ID so should flash to your card unless you are 100% sure they are actually elpida chips. Do you have dual bios on this card?
 

testerr86

Junior Member
Jun 28, 2019
17
2
11
You need to physically inspect them by taking the cooler off. There are only 2 other bios files for the 4gb version of your card (apart from the one you flashed) both are hynix, but they share the same subsystem and device ID so should flash to your card unless you are 100% sure they are actually elpida chips. Do you have dual bios on this card?
I have no clue if it has dual bios or not, though I tried to flash it with other brands' bios too with atifllash but it wouldn't accept.
 

testerr86

Junior Member
Jun 28, 2019
17
2
11
https://www.techpowerup.com/vgabios/211048/211048
https://www.techpowerup.com/vgabios/188897/188897

Hynix bios files

For reference when flashing you need to flash a bios that has the same subsystem and device ID as the GPU you are flashing AS WELL as the same manufacturer vram chips, out of interest why did you flash it in the first place?
ah I bought a mining card and i had to use some sort of patch in order to make it run properly, so just needed to get rid of that crap.
 

ubern00b

Member
Jun 11, 2019
171
74
56
ah I bought a mining card and i had use some sort of patch in order to make it run properly, so just needed to get rid of that crap.
ok let me know how you get on with those files, but 1/both should work, and leave thanks ;)
 

ASK THE COMMUNITY