• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

MSI b450 Tomahawk Max - no screen/display on boot.

adamekcerv

Junior Member
Aug 7, 2015
5
0
66
Hi,
This is my setup:
I've recetly updated BIOS to the newest version. After a while it stopped working (no screen is showing up). When I turn on the PC all fans are spinning and RGB is on. (RAMs RGB is red + red ram indicator on the MOBO).

What I did:

Changed RAM (boot with only one module + reseated to a1/b1), CPU, GPU, source to some different working modules

Changed monitor + cables

Disconnected all drives

cleared CMOS

Tried to flashback some older BIOS version using this manual:

https://www.reddit.com/r/MSI_Gaming/comments/cjfzx4 View: https://www.reddit.com/r/MSI_Gaming/comments/cjfzx4
It didn't work. The PC did turn on after I've pushed the BIOS flashback button, but nothing happened afterwards.
Any other ideas ?

Thank you very much.

Odesláno z mého SM-G965F pomocí Tapatalk
 
Last edited:

DAPUNISHER

Super Moderator and Elite Member
Moderator
Aug 22, 2001
21,923
2,022
136
Successful flashback experiences vary. What works for me: Just the bare board, and pull the CMOS battery out until finished. You already know which USB port to use and button to push. The most important part is getting the USB setup right.

Open a command prompt as admin-
  1. type the following commands
  2. diskpart
  3. list disk
  4. select the number for the USB, it should be 2 looking at your system specs. So you would type select disk 2
  5. detail disk - this will confirm you did not goof the drive number
  6. clean
  7. convert mbr
  8. create partition primary​
Now you can put the file on the drive, rename it MSI.ROM, and run the flashback.
 
  • Like
Reactions: adamekcerv

ASK THE COMMUNITY