• Guest, The rules for the P & N subforum have been updated to prohibit "ad hominem" or personal attacks against other posters. See the full details in the post "Politics and News Rules & Guidelines."

MPC poor performance in Win7

Mischichi

Junior Member
Oct 13, 2013
9
0
0
Well, a long story short.Just switched over from WinXP to Win7 on my HTPC. I formated the HDD and did a clean install of Win7 as i always do.
All HD movies has played smoothly on WinXP, both 720 and 1080, but now on Win7 all movies lags and freezes, and sometimes the sound and image are outsynced.
GPU-Z show me 99% GPU usage constantly when i watch movies


I've used the same MPC settings for a couple years and it has worked just fine for me, but not now anymore.


Usually i use FFDShow and madVR, but i've tried FFDShow + Haali and FFDShow + Haali + Lav filters. But all set ups ends as before, 99% GPU usage


This is strange since it worked flawless in WinXP.


Things i've tried.
*Disable Aero
*Downclock and overclock the GPU
*Played the movie on another discs
*Set up the "High performance" in Power management
*Tried several Nvidia drivers, way back to 2012 drivers


And the HTPC specs.
*Intel i7-930
*Intel X25-M SSD 160GB + several 1TB WD discs
*Corsair HX 850W
*Corsair Dominator DHX+ DDR3 1600MHz 6GB
*Geforce GT 520 "not the best GPU but it did the job in WinXP"


There's absolutely no temperature problem and all drivers are up to date


Any settings i've missed?
 

Auric

Diamond Member
Oct 11, 1999
9,596
2
71
Just use the current MPC-HC (which includes LAV) and madVR. In LAV Video, set Hardware Acceleration to None. In madVR pay particular attention to the scaling options.
 

cheez

Golden Member
Nov 19, 2010
1,722
67
91
Well, a long story short.Just switched over from WinXP to Win7 on my HTPC. I formated the HDD and did a clean install of Win7 as i always do.
All HD movies has played smoothly on WinXP, both 720 and 1080, but now on Win7 all movies lags and freezes, and sometimes the sound and image are outsynced.
GPU-Z show me 99% GPU usage constantly when i watch movies


I've used the same MPC settings for a couple years and it has worked just fine for me, but not now anymore.


Usually i use FFDShow and madVR, but i've tried FFDShow + Haali and FFDShow + Haali + Lav filters. But all set ups ends as before, 99% GPU usage


This is strange since it worked flawless in WinXP.


Things i've tried.
*Disable Aero
*Downclock and overclock the GPU
*Played the movie on another discs
*Set up the "High performance" in Power management
*Tried several Nvidia drivers, way back to 2012 drivers


And the HTPC specs.
*Intel i7-930
*Intel X25-M SSD 160GB + several 1TB WD discs
*Corsair HX 850W
*Corsair Dominator DHX+ DDR3 1600MHz 6GB
*Geforce GT 520 "not the best GPU but it did the job in WinXP"


There's absolutely no temperature problem and all drivers are up to date


Any settings i've missed?
Sounds like it's not properly utilizing the hardware acceleration.

The problem is that your MPC player is too old for the new direct X components in Windows 7 to handle. It's a compatibility issue.


For old hardware, stick with old OS, old drivers, old player.

For new hardware, stick with new OS, new drivers, and new player.


cheez
 
Last edited:

mindbomb

Senior member
May 30, 2013
364
0
0
auric is correct. Install just mpc hc and madvr. Uninstall haali and ffdshow.
then configure madvr to use bilinear scaling for image up, image down, and chroma.
 

ASK THE COMMUNITY

TRENDING THREADS